aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGarek Dyszel <garekdyszel@disroot.org>2022-09-07 14:34:29 -0400
committerJulien Lepiller <julien@lepiller.eu>2022-09-24 20:24:52 +0200
commitd46e955d93692f3c4b5387aaf709a2e5e43b57b4 (patch)
treefe2fc9c2410a1c8b5dddc7241ad193efb3688cc7
parent13c1ed6a198985141f13fb1899bb5fc05f408915 (diff)
downloadguix-d46e955d93692f3c4b5387aaf709a2e5e43b57b4.tar
guix-d46e955d93692f3c4b5387aaf709a2e5e43b57b4.tar.gz
gnu: Add python-icdiff.
* gnu/packages/python-xyz.scm (python-icdiff): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c41e7dbf5d..ffcb023d60 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19684,6 +19684,26 @@ point is the point of maximum curvature.")
perform the operations required for synchronizing plain text.")
(license license:asl2.0)))
+(define-public python-icdiff
+ (package
+ (name "python-icdiff")
+ (version "2.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeffkaufman/icdiff")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14gr9j2h7sfw47pwfzspm4zinywhqmzm4a0qz5c2k9wbixz120a4"))))
+ (build-system python-build-system)
+ (home-page "https://www.jefftk.com/icdiff")
+ (synopsis "Improved colored diff")
+ (description "This package provides colored diff functions that highlight
+parts of the lines that were modified.")
+ (license license:psfl)))
+
(define-public python-dirsync
(package
(name "python-dirsync")