aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-01-17 17:14:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:13:16 +0100
commitcba386c1295b7054df22dfb4662b1b92f668e2c0 (patch)
tree76078a073f62240b582c39cc20f8c9625edb6380
parent341afe2a36125b11c1bc08bdc8f63421edaba008 (diff)
downloadguix-cba386c1295b7054df22dfb4662b1b92f668e2c0.tar
guix-cba386c1295b7054df22dfb4662b1b92f668e2c0.tar.gz
build: Expand ‘scripts/guix’ at Make time.
This moves the complexity of Autotools variable expansion outside of the application code. * scripts/guix.in (config-lookup): Delete. (maybe-augment-load-paths!, run-guix-main): Use fully expanded variables instead of calling ‘config-lookup’. * configure.ac: Don't use AC_CONFIG_FILES for ‘scripts/guix’. Use AC_PROG_SED. * Makefile.am (scripts/guix): New rule. (do_subst): New variable. (CLEANFILES, EXTRA_DIST): Adapt. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--Makefile.am20
-rw-r--r--configure.ac3
-rw-r--r--scripts/guix.in31
3 files changed, 25 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index aebd3b1eb7..9bafdab49b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
-# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+# Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2016, 2017 Mark H Weaver <mhw@netris.org>
# Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
# Copyright © 2017 Leo Famulari <leo@famulari.name>
@@ -26,8 +26,20 @@
# You should have received a copy of the GNU General Public License
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-bin_SCRIPTS = \
- scripts/guix
+bin_SCRIPTS = scripts/guix
+
+# Handle substitution of fully-expanded Autoconf variables.
+do_subst = $(SED) \
+ -e 's,[@]GUILE[@],$(GUILE),g' \
+ -e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
+ -e 's,[@]guileobjectdir[@],$(guileobjectdir),g' \
+ -e 's,[@]localedir[@],$(localedir),g'
+
+scripts/guix: scripts/guix.in Makefile
+ $(AM_V_at)rm -f $@ $@-t
+ $(AM_V_at)$(MKDIR_P) "$(@D)"
+ $(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"
+ $(AM_V_at)chmod a+x,a-w "$@-t" && mv -f "$@-t" "$@"
nodist_noinst_SCRIPTS = \
pre-inst-env \
@@ -437,6 +449,7 @@ EXTRA_DIST = \
TODO \
CODE-OF-CONDUCT \
.dir-locals.el \
+ bin/guix.in \
build-aux/build-self.scm \
build-aux/compile-all.scm \
build-aux/hydra/evaluate.scm \
@@ -473,6 +486,7 @@ endif !BUILD_DAEMON_OFFLOAD
CLEANFILES = \
+ $(bin_SCRIPTS) \
$(GOBJECTS) \
$(SCM_TESTS:tests/%.scm=%.log)
diff --git a/configure.ac b/configure.ac
index 1e39122483..f69f796484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,8 @@ dnl Make sure we don't suffer from the bug in 'equal?' wrt. syntax objects
dnl found in 2.2.1. See <https://bugs.gnu.org/29903>.
GUIX_ASSERT_SYNTAX_OBJECT_EQUAL
+AC_PROG_SED
+
dnl Decompressors, for use by the substituter and other modules.
AC_PATH_PROG([GZIP], [gzip])
AC_PATH_PROG([BZIP2], [bzip2])
@@ -272,7 +274,6 @@ AC_CONFIG_FILES([Makefile
po/packages/Makefile.in
guix/config.scm])
-AC_CONFIG_FILES([scripts/guix], [chmod +x scripts/guix])
AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
[chmod +x pre-inst-env])
diff --git a/scripts/guix.in b/scripts/guix.in
index e20c274242..af50a782bb 100644
--- a/scripts/guix.in
+++ b/scripts/guix.in
@@ -3,6 +3,7 @@
!#
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,35 +23,15 @@
;; IMPORTANT: We must avoid loading any modules from Guix here,
;; because we need to adjust the guile load paths first.
;; It's okay to import modules from core Guile though.
-(use-modules (ice-9 regex)
- (srfi srfi-26))
+(use-modules (srfi srfi-26))
(let ()
(define-syntax-rule (push! elt v) (set! v (cons elt v)))
- (define config-lookup
- (let ((config '(("prefix" . "@prefix@")
- ("exec_prefix" . "@exec_prefix@")
- ("datarootdir" . "@datarootdir@")
- ("guilemoduledir" . "@guilemoduledir@")
- ("guileobjectdir" . "@guileobjectdir@")
- ("localedir" . "@localedir@")))
- (var-ref-regexp (make-regexp "\\$\\{([a-z_]+)\\}")))
- (define (expand-var-ref match)
- (lookup (match:substring match 1)))
- (define (expand str)
- (regexp-substitute/global #f var-ref-regexp str
- 'pre expand-var-ref 'post))
- (define (lookup name)
- (expand (assoc-ref config name)))
- lookup))
-
(define (maybe-augment-load-paths!)
(unless (getenv "GUIX_UNINSTALLED")
- (let ((module-dir (config-lookup "guilemoduledir"))
- (object-dir (config-lookup "guileobjectdir")))
- (push! module-dir %load-path)
- (push! object-dir %load-compiled-path))
+ (push! "@guilemoduledir@" %load-path)
+ (push! "@guileobjectdir@" %load-compiled-path)
(let ((updates-dir (and=> (or (getenv "XDG_CONFIG_HOME")
(and=> (getenv "HOME")
(cut string-append <> "/.config")))
@@ -64,8 +45,8 @@
(define (run-guix-main)
(let ((guix-main (module-ref (resolve-interface '(guix ui))
'guix-main)))
- (bindtextdomain "guix" (config-lookup "localedir"))
- (bindtextdomain "guix-packages" (config-lookup "localedir"))
+ (bindtextdomain "guix" "@localedir@")
+ (bindtextdomain "guix-packages" "@localedir@")
(apply guix-main (command-line))))
(maybe-augment-load-paths!)