aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 23:46:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:04 -0500
commitbc17fadbb63e6eec9759a224af4c515a3a175875 (patch)
tree5366da346ecbda606f5b14aab7bcbb48f69ddf07
parentcf264b404c8ad2e433141696d81e55df2d152df2 (diff)
downloadguix-bc17fadbb63e6eec9759a224af4c515a3a175875.tar
guix-bc17fadbb63e6eec9759a224af4c515a3a175875.tar.gz
gnu: ceph: Streamline use of PYTHONPATH.
* gnu/packages/storage.scm (ceph) [phases]{set-install-environment}: Just add what's needed to PYTHONPATH.
-rw-r--r--gnu/packages/storage.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 978ecd5b5e..4c2fa21a78 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -168,10 +168,7 @@
"/site-packages")))
;; The Python install scripts refuses to function if
;; the install directory is not on PYTHONPATH.
- (setenv "PYTHONPATH"
- (string-append py3sitedir ":"
- (getenv "GUIX_PYTHONPATH")))
- #t)))
+ (setenv "PYTHONPATH" py3sitedir))))
(add-after 'install 'wrap-python-scripts
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))