aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 21:09:50 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 10:55:06 +0100
commitbba0676e86601c248cd0f3642a90b061af1f5b4d (patch)
tree91ecaa129e2662e7663694beb5dae10984509686
parentbbb9b663161cd836107881b84a09b85aabdd62a9 (diff)
downloadguix-bba0676e86601c248cd0f3642a90b061af1f5b4d.tar
guix-bba0676e86601c248cd0f3642a90b061af1f5b4d.tar.gz
gnu: python-tzlocal: Update to 5.2.
* gnu/packages/time.scm (python-tzlocal): Update to 5.2. [source]: Fetch from git. [build-system]: Use pyproject-build-system [propagated-inputs]: Remove python-pytz. Add python-tzdata. [native-inputs]: Add python-check-manifest, python-pytest, and python-pytest-cov.
-rw-r--r--gnu/packages/time.scm33
1 files changed, 13 insertions, 20 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 5e8fcf05d9..b0d800da94 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -375,32 +375,25 @@ timezone for given coordinates on earth entirely offline.")
(define-public python-tzlocal
(package
(name "python-tzlocal")
- (version "2.1")
+ (version "5.2")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "tzlocal" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/regebro/tzlocal")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0i1fm4sl04y65qnaqki0w75j34w863gxjj8ag0vwgvaa572rfg34"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-symlink-test
- ;; see: https://github.com/regebro/tzlocal/issues/53
- (lambda _
- (delete-file "tests/test_data/symlink_localtime/etc/localtime")
- (symlink "../usr/share/zoneinfo/Africa/Harare"
- "tests/test_data/symlink_localtime/etc/localtime")
- ;; And skip the test_fail test, it is known to fail
- (substitute* "tests/tests.py"
- (("def test_fail") "def _test_fail"))
- #t)))))
+ "1apa3i5fsfw28jnaaaa7jr976y5wbifl3h04id0bvplvsb9zpmy7"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-pytz))
+ (list python-tzdata))
(native-inputs
- (list python-mock))
+ (list python-check-manifest
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock))
(home-page "https://github.com/regebro/tzlocal")
(synopsis "Local timezone information for Python")
(description