aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-17 18:58:23 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-19 16:45:38 +0200
commitbb089f76227666e11e6949038c4fd9e130e047a3 (patch)
tree34af56352d6c8dc3588baea4326f401b00d18922
parente9e60b3a1dd2f88da4e1634e1c0f73077054aca6 (diff)
downloadguix-bb089f76227666e11e6949038c4fd9e130e047a3.tar
guix-bb089f76227666e11e6949038c4fd9e130e047a3.tar.gz
maint: Resurrect running `make' from a tarball.
This is a follow-up to commit 8b972da068708a8b17f3ab153ea940690ca49ca9 Makefile.am: Auto-configure Git on 'make'. * configure.ac (in_git_p): New conditional. * Makefile.am (nodist_noinst_DATA): Use it to only enable this when building from Git. Change-Id: I09a90a59a4933a8cdb04124467d38209171f2a57
-rw-r--r--Makefile.am5
-rw-r--r--configure.ac10
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 25b3eb3378..98008c528d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1241,7 +1241,12 @@ COMMIT_MSG_MAGIC = VGhpcyBpcyB0aGUgY29tbWl0LW1zZyBob29rIG9mIEd1aXg=
cp etc/git/commit-msg $@; \
fi
+# The etc/git/ config files are not distributed and have no use when building
+# from a tarball. Do not add dependencies on these to *_DATA when building
+# from a tarball, as that breaks the build.
+if in_git_p
nodist_noinst_DATA = .git/hooks/pre-push .git/config .git/hooks/commit-msg
+endif
# Downloading up-to-date PO files.
diff --git a/configure.ac b/configure.ac
index ecbd596a34..8c3a06da37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -265,6 +265,16 @@ dnl Documentation translation.
AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
+AC_MSG_CHECKING([if building from git])
+if test -e .git; then
+ in_git_p=yes
+else
+ in_git_p=no
+fi
+AC_MSG_RESULT([$in_git_p])
+AM_CONDITIONAL([in_git_p],
+ [test "x$in_git_p" = "xyes"])
+
case "$storedir" in
/gnu/store)
;;