aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-14 10:23:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:20 +0200
commitb87fc11627a8da47a0309647ad78a94bf4a87ba8 (patch)
tree2cb6e39cfe98ebf9e1493edf349d9eda02509efe
parentb15eee1bfa1850fbe6d49760fc7547a325a5ac04 (diff)
downloadguix-b87fc11627a8da47a0309647ad78a94bf4a87ba8.tar
guix-b87fc11627a8da47a0309647ad78a94bf4a87ba8.tar.gz
gnu: Add rust-objc2-metal-0.2.
* gnu/packages/crates-apple.scm (rust-objc2-metal-0.2): New variable. Change-Id: I32b8d1f2b68c77dd11d0896d98f7c7e28c5b0ef4
-rw-r--r--gnu/packages/crates-apple.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 4f3dedcdf0..fea08bfc87 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -1476,6 +1476,30 @@ the Cocoa Foundation framework.")
"This package provides bindings to the @code{LinkPresentation} framework.")
(license license:expat)))
+(define-public rust-objc2-metal-0.2
+ (package
+ (name "rust-objc2-metal")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "objc2-metal" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1mmdga66qpxrcfq3gxxhysfx3zg1hpx4z886liv3j0pnfq9bl36x"))))
+ (build-system cargo-build-system)
+ (arguments
+ ;; Must specify the desired runtime using Cargo features on non-Apple platforms
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-block2" ,rust-block2-0.5)
+ ("rust-objc2" ,rust-objc2-0.5)
+ ("rust-objc2-foundation" ,rust-objc2-foundation-0.2))))
+ (home-page "https://github.com/madsmtm/objc2")
+ (synopsis "Bindings to the Metal framework")
+ (description "This package provides bindings to the Metal framework.")
+ (license license:expat)))
+
(define-public rust-objc2-proc-macros-0.1
(package
(name "rust-objc2-proc-macros")