aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-09-19 19:38:16 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-09-22 07:34:02 +0200
commitb7971ff798d2d400bac0293bd8d86175433fec6b (patch)
tree69f3852dadf546fb12de57261f24a9c0a3e1b9c8
parent728d5b6b0684727e8f1611d3e0f9cc293dd395d2 (diff)
downloadguix-b7971ff798d2d400bac0293bd8d86175433fec6b.tar
guix-b7971ff798d2d400bac0293bd8d86175433fec6b.tar.gz
gnu: lablgtk3: Update to 3.1.2.
* gnu/packages/ocaml.scm (lablgtk3): Update to 3.1.2. [arguments]: Do not build extensions anymore (missing dependency) * gnu/packages/games.scm (laby)[inputs]: Use `ocaml-lablgtk3-sourceview3'. * gnu/packages/maths.scm (frama-c)[inputs]: Use `ocaml-lablgtk3-sourceview3'. * gnu/packages/coq.scm (coq-ide)[inputs]: Use `ocaml-lablgtk3-sourceview3'.
-rw-r--r--gnu/packages/coq.scm2
-rw-r--r--gnu/packages/games.scm7
-rw-r--r--gnu/packages/maths.scm1
-rw-r--r--gnu/packages/ocaml.scm9
4 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index bbb34df27d..faa7b72136 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -148,7 +148,7 @@ It is developed using Objective Caml and Camlp5.")
(propagated-inputs
(list coq coq-ide-server))
(inputs
- `(("lablgtk3" ,lablgtk3)))))
+ (list lablgtk3 ocaml-lablgtk3-sourceview3))))
(define-public proof-general
;; The latest release is from 2016 and there has been more than 450 commits
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0bf36fa620..b209a8a584 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5764,17 +5764,14 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
(patches (search-patches "laby-make-install.patch"))))
(build-system gnu-build-system)
(inputs
- `(("lablgtk3" ,lablgtk3)
- ("ocaml" ,ocaml)
- ("ocaml-findlib" ,ocaml-findlib)
- ("ocamlbuild" ,ocamlbuild)))
+ (list lablgtk3 ocaml-lablgtk3-sourceview3 ocaml ocaml-findlib ocamlbuild))
(arguments
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'set-library-path
(lambda* (#:key inputs #:allow-other-keys)
- (let ((lablgtk (assoc-ref inputs "lablgtk3")))
+ (let ((lablgtk (assoc-ref inputs "lablgtk")))
(setenv "LD_LIBRARY_PATH"
(string-append lablgtk "/lib/ocaml/stublibs"))))))
#:tests? #f ; no 'check' target
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..d3373359b8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7590,6 +7590,7 @@ of C, Java, or Ada programs.")
ocaml-graph
ocaml-yojson
ocaml-zarith
+ ocaml-lablgtk3-sourceview3
lablgtk3
why3))
(native-search-paths
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a995ffe08a..2ac4459b4d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7998,7 +7998,7 @@ support for Mparser.")))
(define-public lablgtk3
(package
(name "lablgtk")
- (version "3.1.1")
+ (version "3.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8007,10 +8007,11 @@ support for Mparser.")))
(file-name (git-file-name name version))
(sha256
(base32
- "11qfc39cmwfwfpwmjh6wh98zwdv6p73bv8hqwcsss869vs1r7gmn"))))
+ "0b17w9qb1f02h3313cm62mrqlhwxficppzm72n7sf8mmwrylxbm7"))))
(build-system dune-build-system)
(arguments
- `(#:test-target "."
+ `(#:package "lablgtk3"
+ #:test-target "."
#:phases
(modify-phases %standard-phases
(add-before 'build 'make-writable
@@ -8026,7 +8027,7 @@ support for Mparser.")))
(propagated-inputs
(list ocaml-cairo2))
(inputs
- (list camlp5 gtk+ gtksourceview-3 gtkspell3))
+ (list camlp5 gtk+))
(native-inputs
(list pkg-config))
(home-page "https://github.com/garrigue/lablgtk")