aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 21:47:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:07 +0200
commitac29f53d304ed6b875562375fbc66c9cd366f8fd (patch)
tree78414d88ab7ef74c6f4eaea0bf1db56448b2c547
parent8ace45c088497583c5a0a03cff3c09600a3d09b9 (diff)
downloadguix-ac29f53d304ed6b875562375fbc66c9cd366f8fd.tar
guix-ac29f53d304ed6b875562375fbc66c9cd366f8fd.tar.gz
gnu: texlive-tex-texinfo -> texlive-texinfo.
* gnu/packages/tex.scm (texlive-texinfo): New variable. (texlive-tex-texinfo): Deprecate variable. * doc/build.scm (pdf-manual): * gnu/packages/finance.scm (optionmatrix): * gnu/packages/lisp.scm (sbcl): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/scheme.scm (mit-scheme): * gnu/packages/xdisorg.scm (xforms): Use new name.
-rw-r--r--doc/build.scm2
-rw-r--r--gnu/packages/finance.scm2
-rw-r--r--gnu/packages/lisp.scm2
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/scheme.scm5
-rw-r--r--gnu/packages/tex.scm38
-rw-r--r--gnu/packages/xdisorg.scm2
7 files changed, 20 insertions, 33 deletions
diff --git a/doc/build.scm b/doc/build.scm
index 995f4878e1..9c0cc99404 100644
--- a/doc/build.scm
+++ b/doc/build.scm
@@ -916,7 +916,7 @@ makeinfo OPTIONS."
texlive-bin ;for GUIX_TEXMF
texlive-epsf
texlive-ec
- texlive-tex-texinfo)))))
+ texlive-texinfo)))))
(define build
(with-imported-modules '((guix build utils))
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index eb480762ed..e0d6bd6e2c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2073,7 +2073,7 @@ trading, and risk management in real-life.")
(list gsl gtk+ ncurses))
(native-inputs
(list pkg-config texinfo
- (texlive-updmap.cfg (list texlive-epsf texlive-tex-texinfo))))
+ (texlive-updmap.cfg (list texlive-epsf texlive-texinfo))))
(home-page "https://anthonybradford.github.io/optionmatrix/")
(synopsis "Financial derivative calculator")
(description
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 37735020ad..900daca53c 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -481,7 +481,7 @@ an interpreter, a compiler, a debugger, and much more.")
ed
inetutils ;for hostname(1)
texinfo
- (texlive-updmap.cfg (list texlive-tex-texinfo))
+ (texlive-updmap.cfg (list texlive-texinfo))
which))
(inputs
(list gmp ; for sb-gmp
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 4a681d3ecb..db14272804 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -325,7 +325,7 @@ colors, styles, options and details.")
texlive-ocgx2
texlive-parskip
texlive-pdftexcmds
- texlive-tex-texinfo))))
+ texlive-texinfo))))
(inputs
(list bash-minimal
eigen
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 215ea741f8..a4f43001ca 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -191,8 +191,9 @@
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("texlive" ,(texlive-updmap.cfg (list texlive-tex-texinfo
- texlive-epsf)))
+ ("texlive" ,(texlive-updmap.cfg
+ (list texlive-epsf
+ texlive-texinfo)))
("texinfo" ,texinfo)
("ghostscript" ,ghostscript)
("m4" ,m4)))
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 884f35c959..a83310619e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6523,34 +6523,18 @@ a few situations where longtable has problems.")
(define-deprecated-package texlive-latex-supertabular texlive-supertabular)
-(define-public texlive-tex-texinfo
+(define-public texlive-texinfo
(package
- (name "texlive-tex-texinfo")
+ (name "texlive-texinfo")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/texinfo"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1qcmcsxdsibca0mad559vhz36xaxsbkivgv1hc98vdyd90fg4y31"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/texinfo")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/texinfo")
- (synopsis "TeX macros to handle Texinfo files")
+ (source (texlive-origin
+ name version
+ (list "tex/texinfo/")
+ (base32
+ "0wbbhjr1jqiicnssiy6n5s4v5p6axhlilpkfhix4kavbj8mb6mfn")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/texinfo")
+ (synopsis "Texinfo documentation system")
(description
"Texinfo is the preferred format for documentation in the GNU project;
the format may be used to produce online or printed output from a single
@@ -6559,6 +6543,8 @@ other programs in the distribution offer online interactive use (with
hypertext linkages in some cases).")
(license license:gpl3+)))
+(define-deprecated-package texlive-tex-texinfo texlive-texinfo)
+
(define-public texlive-textcase
(package
(inherit (simple-texlive-package
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 1f7539764c..da5ca76e10 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3486,7 +3486,7 @@ the following features:
texinfo
texi2html
(texlive-updmap.cfg (list texlive-epsf
- texlive-tex-texinfo))
+ texlive-texinfo))
imagemagick))
(propagated-inputs (list libx11 libxpm libjpeg-turbo))
(home-page "http://xforms-toolkit.org/")