aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2022-08-08 20:10:12 +0200
committerAndreas Enge <andreas@enge.fr>2022-08-08 22:26:10 +0200
commitaa83dde4b79501e4bf29f290bffbfe68581b8427 (patch)
tree3864d1598c3e8fd5b9c53337e8bc58021a09695a
parent2a428633a72d49efecea8f31012594507cda0775 (diff)
downloadguix-aa83dde4b79501e4bf29f290bffbfe68581b8427.tar
guix-aa83dde4b79501e4bf29f290bffbfe68581b8427.tar.gz
gnu: python-gmpy2: Update to 2.1.2.
* gnu/packages/sagemath.scm (python-gmpy2): Update to 2.1.2.
-rw-r--r--gnu/packages/sagemath.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 7f76f8912b..bb80ff4db5 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -69,22 +69,17 @@ PARI/GP. It has been spun off from the SageMath mathematics software system,
but it can be used independently.")
(license license:gpl2+)))
-;; The stable version of the following package is not young enough to be
-;; used with Sage, since it does not support cython; so we use a beta
-;; release.
(define-public python-gmpy2
(package
(name "python-gmpy2")
- (version "2.1.0b1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aleaxit/gmpy")
- (commit (string-append "gmpy2-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ljvnmhxqdfsp0yy4c2hynhk5sggm63kkqsq4iwq4k9vsnx2xm97"))))
+ (version "2.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gmpy2" version))
+ (sha256
+ (base32
+ "1lc29g3s4z5f1qbsc2x9i9sf6wrpni9pwiwmb1wwx3hjr85i8xfs"))))
(build-system python-build-system)
(native-inputs
(list unzip))