aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2018-02-27 05:25:47 +0100
committerChris Marusich <cmmarusich@gmail.com>2018-02-27 05:29:37 +0100
commita1df45e904caf4d26f6e44d07ce74881bb25ecd9 (patch)
tree4b098ab439d2f2bcfb1bb60cefb1372ff162a72d
parent701cfb9b333973f242043497b3231b5ea296282b (diff)
downloadguix-a1df45e904caf4d26f6e44d07ce74881bb25ecd9.tar
guix-a1df45e904caf4d26f6e44d07ce74881bb25ecd9.tar.gz
gnu: commencement: Add commentary regarding grafts.
* gnu/packages/commencement.scm: Add comments that were originally included only in the Git commit message of f00b85ff8d34df0a1879e593d4a85629b8586af7. Co-Authored-By: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 7286e954c5..c38f40f618 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -66,6 +66,15 @@
;;; To avoid circular dependencies, this module should not be imported
;;; directly from anywhere.
;;;
+;;; Below, we frequently use "inherit" to create modified packages. The
+;;; reason why we use "inherit" instead of "package/inherit" is because we do
+;;; not want these commencement packages to inherit grafts. By definition,
+;;; these packages are not depended on at run time by any of the packages we
+;;; use. Thus it does not make sense to inherit grafts. Furthermore, those
+;;; grafts would often lead to extra overhead for users who would end up
+;;; downloading those "-boot0" packages just to build package replacements
+;;; that are in fact not going to be used.
+;;;
;;; Code:
(define gnu-make-boot0