aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-06 08:36:57 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-08 15:28:42 +0800
commit9a56e3e0ada4d072442f4ca3f5cef3f97800459c (patch)
tree4e3cb8d2fd3588bdeb86b61670c3e526a331c1f9
parent812512413ae521faa184f783d69bbfa4a9f492ac (diff)
downloadguix-9a56e3e0ada4d072442f4ca3f5cef3f97800459c.tar
guix-9a56e3e0ada4d072442f4ca3f5cef3f97800459c.tar.gz
gnu: Add hyprwayland-scanner.
* gnu/packages/wm.scm (hyprwayland-scanner): New variable. Change-Id: I492006356e3abc68609d6c73738a0dfd3b15681c
-rw-r--r--gnu/packages/freedesktop.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e98f3bd3b5..bb6a721a41 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -95,6 +95,7 @@
#:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -1339,6 +1340,30 @@ For information about libevdev, see:
Python.")
(license license:lgpl2.0)))
+(define-public hyprwayland-scanner
+ (package
+ (name "hyprwayland-scanner")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprwayland-scanner")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r7ay4zjkfyr0xd73wz99qhnqjq7nma98gm51wm9lmai4igw90qw"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;No tests.
+ (inputs (list pugixml))
+ (native-inputs (list gcc-13 pkg-config))
+ (home-page "https://github.com/hyprwm/hyprwayland-scanner")
+ (synopsis "Hyprland implementation of @code{wayland-scanner}")
+ (description
+ "This package provides a Hyprland implementation of @code{wayland-scanner},
+in and for C++.")
+ (license license:bsd-3)))
+
(define-public wayland
(package
(name "wayland")