aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-03 13:21:46 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-30 17:58:35 +0100
commit91647ba87b065dd054f3b38a4aea2de33f2e12a7 (patch)
treeab55da415613156814409a574fea70d155d0f261
parent104ac4eea67f09c6efdd4e5487d2d61830d3bff9 (diff)
downloadguix-91647ba87b065dd054f3b38a4aea2de33f2e12a7.tar
guix-91647ba87b065dd054f3b38a4aea2de33f2e12a7.tar.gz
gnu: tomlc99: Install pkg-config file.
* gnu/packages/c.scm (tomlc99) <arguments>: Add phase to install pkg-config file. Change-Id: Id09f22912fe7e4dcac6a0377e4a78d3d34346106 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/c.scm33
1 files changed, 23 insertions, 10 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 6e98c34af6..1b168d2ca8 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -265,16 +265,29 @@ standard.")
#$(cc-for-target))
(string-append "prefix="
#$output))
- #:phases #~(modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda* (#:key tests? make-flags
- #:allow-other-keys)
- (when tests?
- (apply invoke
- `("make" "-C" "unittest"
- ,@make-flags))
- (invoke "./unittest/t1")))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? make-flags
+ #:allow-other-keys)
+ (when tests?
+ (apply invoke
+ `("make" "-C" "unittest"
+ ,@make-flags))
+ (invoke "./unittest/t1"))))
+ ;; The Makefile checks for libtoml.pc and only installs if
+ ;; the prefix is /usr/local.
+ (add-after 'install 'install-pkg-config
+ (lambda _
+ (rename-file "libtoml.pc.sample" "libtoml.pc")
+ (substitute* "libtoml.pc"
+ (("^prefix=.*")
+ (string-append "prefix=" #$output "\n")))
+
+ (let ((pc (string-append #$output "/lib/pkgconfig")))
+ (mkdir-p pc)
+ (install-file "libtoml.pc" pc)))))))
(home-page "https://github.com/cktan/tomlc99")
(synopsis "TOML library for C")
(description