aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:52:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:40 +0200
commit8b8637079cb13d913927444ffd989cea1cbbd615 (patch)
tree79b9ae8da3eb54b326dd57f095caae8187e0c009
parent4442aa8780dfaf5d40dee63ffd0d61222ab73eb0 (diff)
downloadguix-8b8637079cb13d913927444ffd989cea1cbbd615.tar
guix-8b8637079cb13d913927444ffd989cea1cbbd615.tar.gz
gnu: newsboat: Honor the #:tests? flag.
* gnu/packages/syndication.scm (newsboat)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag. Change-Id: I626787ac2d33dfd1e003a0a8e8758e563c664f90
-rw-r--r--gnu/packages/syndication.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 8f2882cff9..4d9811096b 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -309,9 +309,10 @@ cards.")
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
(replace 'check
- (lambda args
- ((assoc-ref gnu:%standard-phases 'check)
- #:test-target "test")))
+ (lambda* (#:key tests? #:allow-other-keys #:rest args)
+ (when tests?
+ ((assoc-ref gnu:%standard-phases 'check)
+ #:test-target "test"))))
(replace 'install
(assoc-ref gnu:%standard-phases 'install)))))
(native-search-paths