aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-11 23:04:26 +0200
committerMarius Bakke <marius@gnu.org>2022-09-14 21:08:34 +0200
commit883d4e0abfaaaa707268d36f01976ed4c54381d8 (patch)
tree032471a86cee7fdc5cbafd92fd9eeca810e6a51b
parent8bd7cd34bf63851d26d3205ccb98d0adbf5d51e5 (diff)
downloadguix-883d4e0abfaaaa707268d36f01976ed4c54381d8.tar
guix-883d4e0abfaaaa707268d36f01976ed4c54381d8.tar.gz
gnu: python-scikit-learn: Update to 1.1.2.
* gnu/packages/machine-learning.scm (python-scikit-learn): Update to 1.1.2.
-rw-r--r--gnu/packages/machine-learning.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index c61428486c..0a12065978 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1097,7 +1097,7 @@ computing environments.")
(define-public python-scikit-learn
(package
(name "python-scikit-learn")
- (version "1.0.2")
+ (version "1.1.2")
(source
(origin
(method git-fetch)
@@ -1107,7 +1107,7 @@ computing environments.")
(file-name (git-file-name name version))
(sha256
(base32
- "1rli53544vlsnmx4v4xcb8fdqcy5n3zksl4plwp76gsmrppb2lig"))))
+ "0wcngyfm2fl3vgyi2aq6j5fvky5185xjzgip64968wqj1hmir5nv"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1128,10 +1128,14 @@ computing environments.")
;; Some tests require write access to $HOME.
(setenv "HOME" "/tmp")
- (invoke "pytest" "sklearn" "-m" "not network"
- "-n" (number->string (parallel-job-count))
- ;; This test tries to access the internet.
- "-k" "not test_load_boston_alternative")))))))
+ ;; Step out of the source directory to avoid interference;
+ ;; we want to run the installed code with extensions etc.
+ (with-directory-excursion "/tmp"
+ (invoke "pytest" "-vv" "--pyargs" "sklearn"
+ "-m" "not network"
+ "-n" (number->string (parallel-job-count))
+ ;; This test tries to access the internet.
+ "-k" "not test_load_boston_alternative"))))))))
(inputs (list openblas))
(native-inputs
(list python-cython