aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-06 16:31:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-06 16:56:08 -0400
commit8515a506ca71ae5e3709930754d6df77614ffb71 (patch)
treefc434a63f99ae3610f136f1e149a3bdfe5eb6e46
parent41d0b233bac19a2ce0289bf2279a1e7f831b8aee (diff)
downloadguix-8515a506ca71ae5e3709930754d6df77614ffb71.tar
guix-8515a506ca71ae5e3709930754d6df77614ffb71.tar.gz
gnu: qemu: Fix the Texinfo manual.
The makeinfo command splits the generated info output in multiple files (in 300 KiB chunks) by default; this meant the build system would have had to install the multiple QEMU.info-1, QEMU.info-2, etc. files for the info manual to work as intended. Instead, keep the info manual as one single file by specifying the --no-split option to makeinfo. * gnu/packages/patches/qemu-build-info-manual.patch (sphinxinfo) <makeinfo>: Invoke with the --no-split argument.
-rw-r--r--gnu/packages/patches/qemu-build-info-manual.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/patches/qemu-build-info-manual.patch b/gnu/packages/patches/qemu-build-info-manual.patch
index c837040d45..f2bee30ab0 100644
--- a/gnu/packages/patches/qemu-build-info-manual.patch
+++ b/gnu/packages/patches/qemu-build-info-manual.patch
@@ -90,7 +90,7 @@ index ebd85d59f9..1243839461 100644
+ output: 'QEMU.info',
+ install: true,
+ install_dir: get_option('infodir'),
-+ command: [makeinfo, '@INPUT0@', '--output=@OUTPUT@'])
++ command: [makeinfo, '--no-split', '@INPUT0@', '--output=@OUTPUT@'])
+ alias_target('texi', sphinxtexi)
+ alias_target('info', sphinxinfo)
+ endif