aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-12-23 10:16:55 +0300
committerLudovic Courtès <ludo@gnu.org>2024-01-14 23:00:04 +0100
commit80bec14a9e4797ae436b113c7e0d9be52a17a1d7 (patch)
tree29aa49187913dec34698f62a27c70611d978abfd
parentfe736803da060559f90e6e52fa61397f765336a3 (diff)
downloadguix-80bec14a9e4797ae436b113c7e0d9be52a17a1d7.tar
guix-80bec14a9e4797ae436b113c7e0d9be52a17a1d7.tar.gz
gnu: guile-ssh: Update to 0.16.4.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.16.4. [arguments]: Improve the style. Change-Id: Ib7d741e7f4fc7a1fc167cfa4f7953f84d9f4d390 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ssh.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 0b364bbe90..2a5c0541cc 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -324,7 +324,7 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.16.3")
+ (version "0.16.4")
(home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
(method git-fetch)
@@ -334,7 +334,7 @@ Additionally, various channel-specific options can be negotiated.")
(file-name (git-file-name name version))
(sha256
(base32
- "0b03aizjdj3g15xfkspgvy8k5jl8bgv4q7gwjwr3l2ibqkrm8vrz"))))
+ "127yhjaywais3h2g3cxhqmhdmqgxf9j1jwb6wzx92j0z7asrjqwr"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -362,8 +362,7 @@ Additionally, various channel-specific options can be negotiated.")
(parallel-job-count)))
(substitute* (find-files "." "\\.scm$")
(("\"libguile-ssh\"")
- (string-append "\"" lib "/libguile-ssh\"")))
- #t)))
+ (string-append "\"" lib "/libguile-ssh\""))))))
,@(if (%current-target-system)
'()
'((add-before 'check 'fix-guile-path
@@ -371,8 +370,7 @@ Additionally, various channel-specific options can be negotiated.")
(let ((guile (assoc-ref inputs "guile")))
(substitute* "tests/common.scm"
(("/usr/bin/guile")
- (string-append guile "/bin/guile")))
- #t)))))
+ (string-append guile "/bin/guile"))))))))
(add-after 'install 'remove-bin-directory
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -384,8 +382,7 @@ Additionally, various channel-specific options can be negotiated.")
(string-append examples "/ssshd.scm"))
(rename-file (string-append bin "/sssh.scm")
(string-append examples "/sssh.scm"))
- (delete-file-recursively bin)
- #t))))))
+ (delete-file-recursively bin)))))))
(native-inputs (list autoconf
automake
libtool