aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-03 18:07:16 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-23 07:46:27 -0500
commit7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3 (patch)
tree2dcb4fc2ac73de12639f61d030660eb165e137de
parent20626f62c41c7787ab50d21e961de857f6616d81 (diff)
downloadguix-7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3.tar
guix-7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3.tar.gz
gnu: gnucash: Convert price-quotes-perl patch to a phase.
* gnu/packages/patches/gnucash-price-quotes-perl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/gnucash.scm (gnucash)[patches]: Remove it. [phases]{fix-finance-quote-check}: Implement it using SUBSTITUTES*.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnucash.scm10
-rw-r--r--gnu/packages/patches/gnucash-price-quotes-perl.patch24
3 files changed, 8 insertions, 27 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 750e67d2fe..cd4fc7fb5a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -831,7 +831,6 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-todo-libical-compat.patch \
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
- %D%/packages/patches/gnucash-price-quotes-perl.patch \
%D%/packages/patches/gnucash-disable-failing-tests.patch \
%D%/packages/patches/gnucash-fix-test-transaction-failure.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index e85a538c46..015e2b0459 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -60,8 +60,7 @@
(sha256
(base32
"0grr5qi5rn1xvr7qx5d7mcxa2mcgycy2b325ry73bb485a6yv5l3"))
- (patches (search-patches "gnucash-price-quotes-perl.patch"
- "gnucash-disable-failing-tests.patch"
+ (patches (search-patches "gnucash-disable-failing-tests.patch"
"gnucash-fix-test-transaction-failure.patch"))))
(build-system cmake-build-system)
(inputs
@@ -119,6 +118,13 @@
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))
#t)))
+ ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
+ ;; execute them with perl, so execute them directly instead.
+ (add-after 'unpack 'fix-finance-quote-check
+ (lambda _
+ (substitute* "libgnucash/scm/price-quotes.scm"
+ (("\"perl\" \"-w\" ") ""))
+ #t))
;; There are about 100 megabytes of documentation.
(add-after 'install 'install-docs
(lambda* (#:key inputs outputs #:allow-other-keys)
diff --git a/gnu/packages/patches/gnucash-price-quotes-perl.patch b/gnu/packages/patches/gnucash-price-quotes-perl.patch
deleted file mode 100644
index 3101ddb007..0000000000
--- a/gnu/packages/patches/gnucash-price-quotes-perl.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-After wrapping gnc-fq-check and gnc-fq-helper we can no longer execute them
-with perl, so execute them directly instead.
-
-diff -ur gnucash-3.2.old/libgnucash/scm/price-quotes.scm gnucash-3.2/libgnucash/scm/price-quotes.scm
---- gnucash-3.2.old/libgnucash/scm/price-quotes.scm 2018-09-15 00:48:33.718389646 -0400
-+++ gnucash-3.2/libgnucash/scm/price-quotes.scm 2018-09-15 13:51:49.249862724 -0400
-@@ -74,7 +74,7 @@
- (define (start-program)
- (if (not (string-null? gnc:*finance-quote-check*))
- (set! program (gnc-spawn-process-async
-- (list "perl" "-w" gnc:*finance-quote-check*) #t))))
-+ (list gnc:*finance-quote-check*) #t))))
-
- (define (get-sources)
- (if (not (null? program))
-@@ -158,7 +158,7 @@
- (define (start-quoter)
- (if (not (string-null? gnc:*finance-quote-helper*))
- (set! quoter (gnc-spawn-process-async
-- (list "perl" "-w" gnc:*finance-quote-helper*) #t))))
-+ (list gnc:*finance-quote-helper*) #t))))
-
- (define (get-quotes)
- (if (not (null? quoter))