aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-20 20:02:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:27 +0200
commit794e079437c8687f49d294322dab3b7a8a6abacf (patch)
tree668247c564934d6812ac74f447be29ebc66662d0
parent3bda9591a17d4ad02aaa78da98208a93c6c58e9f (diff)
downloadguix-794e079437c8687f49d294322dab3b7a8a6abacf.tar
guix-794e079437c8687f49d294322dab3b7a8a6abacf.tar.gz
gnu: rust-security-framework-2: Update to 2.11.1.
* gnu/packages/crates-apple.scm (rust-security-framework-2): Update to 2.11.1. [cargo-inputs]: Replace rust-bitflags-1 with 2. [cargo-development-inputs]: Replace rust-x509-parser-0.15 with 0.16. Change-Id: I9c0ad8415d7a5f744cdd9cad6e0a614001e25266
-rw-r--r--gnu/packages/crates-apple.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index aaea2ce7f0..42b3137a7e 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -1673,19 +1673,19 @@ currently pressed on macOS.")
(define-public rust-security-framework-2
(package
(name "rust-security-framework")
- (version "2.9.2")
+ (version "2.11.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "security-framework" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1pplxk15s5yxvi2m1sz5xfmjibp96cscdcl432w9jzbk0frlzdh5"))))
+ (base32 "00ldclwx78dm61v7wkach9lcx76awlrv0fdgjdwch4dmy12j4yw9"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ;missing files
+ `(#:tests? #f ; unresolved import `security_framework::secure_transport`
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1)
+ (("rust-bitflags" ,rust-bitflags-2)
("rust-core-foundation" ,rust-core-foundation-0.9)
("rust-core-foundation-sys" ,rust-core-foundation-sys-0.8)
("rust-libc" ,rust-libc-0.2)
@@ -1697,7 +1697,7 @@ currently pressed on macOS.")
("rust-hex" ,rust-hex-0.4)
("rust-tempdir" ,rust-tempdir-0.3)
("rust-time" ,rust-time-0.3)
- ("rust-x509-parser" ,rust-x509-parser-0.15))))
+ ("rust-x509-parser" ,rust-x509-parser-0.16))))
(home-page "https://lib.rs/crates/security_framework")
(synopsis "@code{Security.framework} bindings for macOS and iOS")
(description "This package provides @code{Security.framework} bindings for