aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-12-28 18:19:53 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-20 10:15:30 +0100
commit76c054a2ff3d802e6d5ed6c2472acc44624fb601 (patch)
tree8613e4804e69a842f31ccda7910ed3bbdd49f292
parent4445ad84ba3e97bd1428565a6f91acf42be4691b (diff)
downloadguix-76c054a2ff3d802e6d5ed6c2472acc44624fb601.tar
guix-76c054a2ff3d802e6d5ed6c2472acc44624fb601.tar.gz
gnu: glib-networking: Disable broken TLS1.2 test.
* gnu/packages/patches/glib-networking-disable-connection-tls1.2-test.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnome.scm (glib-networking): Use it. Change-Id: Ic6b48cb90919e133356d688df692f15ca9a51e79
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/patches/glib-networking-disable-connection-tls1.2-test.patch18
3 files changed, 23 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b63fe38d6c..a22065630b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1315,6 +1315,7 @@ dist_patch_DATA = \
%D%/packages/patches/gitg-fix-positional-argument.patch \
%D%/packages/patches/gklib-suitesparse.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
+ %D%/packages/patches/glib-networking-disable-connection-tls1.2-test.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \
%D%/packages/patches/glib-skip-failing-test.patch \
%D%/packages/patches/glibc-2.33-riscv64-miscompilation.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6cb60ff628..1654b2b61e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4840,7 +4840,10 @@ indicators etc).")
(base32
"0s42l6dkajciqc99zp6dc9l8yv9g8w7d8mgv97l7h7drgd60hand"))
(patches
- (search-patches "glib-networking-gnutls-binding.patch"))))
+ ;; Fixed in 2.76.0
+ ;; see https://gitlab.gnome.org/GNOME/glib-networking/-/issues/201
+ (search-patches "glib-networking-disable-connection-tls1.2-test.patch"
+ "glib-networking-gnutls-binding.patch"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config gettext-minimal))
diff --git a/gnu/packages/patches/glib-networking-disable-connection-tls1.2-test.patch b/gnu/packages/patches/glib-networking-disable-connection-tls1.2-test.patch
new file mode 100644
index 0000000000..fc61be38b6
--- /dev/null
+++ b/gnu/packages/patches/glib-networking-disable-connection-tls1.2-test.patch
@@ -0,0 +1,18 @@
+diff -u a/tls/tests/meson.build b/tls/tests/meson.build
+--- a/tls/tests/meson.build 2023-12-28 18:16:09.665443016 +0100
++++ b/tls/tests/meson.build 2023-12-28 18:16:47.517128845 +0100
+@@ -94,14 +94,5 @@
+ ]
+
+ test(program_name, exe, env: test_envs, depends: program[4])
+-
+- if program[0] == 'connection'
+- # Run the tests again, this time with TLS 1.3 disabled so we can test TLS 1.2.
+- if backend == 'gnutls'
+- test(program_name + '-tls1.2', exe, env: test_envs + ['G_TLS_GNUTLS_PRIORITY=NORMAL:%COMPAT:!VERS-TLS1.3'])
+- elif backend == 'openssl'
+- test(program_name + '-tls1.2', exe, env: test_envs + ['G_TLS_OPENSSL_MAX_PROTO=0x0303'])
+- endif
+- endif
+ endforeach
+ endforeach