aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-06 23:29:41 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-06 23:51:04 +0200
commit72c62716befc0e428125ad4a0f784d2217d153bc (patch)
tree3dc19bd57afe3e0b45de2e9bf34d78c95e2f5a2e
parentf073e52382d2ddcc638de73533bbf798f600d78a (diff)
downloadguix-72c62716befc0e428125ad4a0f784d2217d153bc.tar
guix-72c62716befc0e428125ad4a0f784d2217d153bc.tar.gz
import: snix: Adjust names of license attributes.
* guix/import/snix.scm (license-variable): Adjust names to current Nixpkgs.
-rw-r--r--guix/import/snix.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/guix/import/snix.scm b/guix/import/snix.scm
index adcea43c88..033b7165d3 100644
--- a/guix/import/snix.scm
+++ b/guix/import/snix.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2010, 2011, 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -323,12 +323,12 @@ attributes, or #f if NAME cannot be found."
;; licenses. These are listed in lib/licenses.nix.
(match (and=> (find-attribute-by-name "shortName" license)
attribute-value)
- ("AGPL-3.0+" 'agpl3+)
- ("GPL-2.0+" 'gpl2+)
- ("GPL-3.0+" 'gpl3+)
- ("LGPL-2.0+" 'lgpl2.0+)
- ("LGPL-2.1+" 'lgpl2.1+)
- ("LGPL-3.0+" 'lgpl3+)
+ ("agpl3Plus" 'agpl3+)
+ ("gpl2Plus" 'gpl2+)
+ ("gpl3Plus" 'gpl3+)
+ ("lgpl2Plus" 'lgpl2.0+)
+ ("lgpl21Plus" 'lgpl2.1+)
+ ("lgpl3Plus" 'lgpl3+)
((? string? x) x)
(_ license)))
(_ license)))