aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Stefanović <stefanx2ovic@gmail.com>2018-07-21 18:52:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-22 16:25:59 +0200
commit706a6ff1544f2fc4baa1d4d2e1cd093a41411906 (patch)
treeb47e68ba6e2c7a60a71615fe1f24704ea92bbd1c
parent0c468cb52d9d79884c0f3c92c74a0ea8ad11a946 (diff)
downloadguix-706a6ff1544f2fc4baa1d4d2e1cd093a41411906.tar
guix-706a6ff1544f2fc4baa1d4d2e1cd093a41411906.tar.gz
gnu: sddm: Update to 0.18.0.
* gnu/packages/display-managers.scm (sddm): Update to 0.18.0. * gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/display-managers.scm5
-rw-r--r--gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch28
3 files changed, 3 insertions, 32 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8ad81e6935..16521e8e0d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -18,6 +18,7 @@
# Copyright © 2017, 2018 Gábor Boskovits <boskovits@gmail.com>
# Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -1124,7 +1125,6 @@ dist_patch_DATA = \
%D%/packages/patches/scotch-build-parallelism.patch \
%D%/packages/patches/scotch-graph-diam-64.patch \
%D%/packages/patches/scotch-graph-induce-type-64.patch \
- %D%/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch \
%D%/packages/patches/sdl-libx11-1.6.patch \
%D%/packages/patches/seq24-rename-mutex.patch \
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index b0ad3df788..a4ed601ec8 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -135,7 +135,7 @@ Qt-style API for Wayland clients.")
(define-public sddm
(package
(name "sddm")
- (version "0.17.0")
+ (version "0.18.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -144,8 +144,7 @@ Qt-style API for Wayland clients.")
"sddm-" version ".tar.xz"))
(sha256
(base32
- "0ch6rdppgy2vbzw0c2x9a4c6ry46vx7p6b76d8xbh2nvxh23xv0k"))
- (patches (search-patches "sddm-fix-build-with-qt-5.11-1024.patch"))))
+ "0icyi9nqgbp2v6dwh3n3jzff9jv2xy8d4rbsz89hd65x7c3hrv87"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
diff --git a/gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch b/gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch
deleted file mode 100644
index 53c184230a..0000000000
--- a/gnu/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2efc649..8903b52 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -93,7 +95,7 @@
- find_package(XKB REQUIRED)
-
- # Qt 5
--find_package(Qt5 5.6.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools)
-+find_package(Qt5 5.8.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools Test)
-
- # find qt5 imports dir
- get_target_property(QMAKE_EXECUTABLE Qt5::qmake LOCATION)
-diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
-index c9d935a..bb85ddd 100644
---- a/test/CMakeLists.txt
-+++ b/test/CMakeLists.txt
-@@ -2,9 +2,8 @@
-
- include_directories(../src/common)
-
--
- set(ConfigurationTest_SRCS ConfigurationTest.cpp ../src/common/ConfigReader.cpp)
- add_executable(ConfigurationTest ${ConfigurationTest_SRCS})
- add_test(NAME Configuration COMMAND ConfigurationTest)
-
--qt5_use_modules(ConfigurationTest Test)
-+target_link_libraries(ConfigurationTest Qt5::Core Qt5::Test)