aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 22:58:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:07:39 +0100
commit6ae27a1838d93ca66cd620abe7929d39f196f3c5 (patch)
treed4aa716e05a4eb9490079e7c31cff346cc83bbce
parentc4ee1089378e3f9be1156ac0f23086dcde295642 (diff)
downloadguix-6ae27a1838d93ca66cd620abe7929d39f196f3c5.tar
guix-6ae27a1838d93ca66cd620abe7929d39f196f3c5.tar.gz
gnu: Add go-github-com-pion-stun.
* gnu/packages/golang-web.scm (go-github-com-pion-stun): New variable. Change-Id: I30ef8a231fd980ea976f07d108bcd676446161f1
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 16869df0a9..738f6787d0 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1709,6 +1709,41 @@ in Golang.")
packetizer and depacketizer.")
(license license:expat)))
+(define-public go-github-com-pion-stun
+ (package
+ (name "go-github-com-pion-stun")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/stun")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0172fcm1xvzvy3d5lcpscayzpf3i5w4bpfydifdc9l4n2wslx0sm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/pion/stun"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-dtls-v2
+ go-github-com-pion-logging
+ go-github-com-pion-transport-v2))
+ (home-page "https://github.com/pion/stun")
+ (synopsis "Go implementation of STUN")
+ (description
+ "Package @code{stun} implements Session Traversal Utilities for
++NAT (STUN) (@url{https://tools.ietf.org/html/rfc5389, RFC 5389}) protocol and
++@url{https://pkg.go.dev/github.com/pion/stun#Client, client} with no external
++dependencies and zero allocations in hot paths. Client
++@url{https://pkg.go.dev/github.com/pion/stun#WithRTO, supports} automatic
++request retransmissions.")
+ (license license:expat)))
+
(define-public go-github-com-pion-transport
(package
(name "go-github-com-pion-transport")