aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-09-28 10:18:17 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-28 11:31:49 +0200
commit6545438cccc9d2b406998de50266deb2b8d0ce32 (patch)
tree4f2d928e559242d9d5fb5f78fec0c5706a88af51
parent05c13b3149ecba94da30b4cac743f0c770171cf1 (diff)
downloadguix-6545438cccc9d2b406998de50266deb2b8d0ce32.tar
guix-6545438cccc9d2b406998de50266deb2b8d0ce32.tar.gz
gnu: Add soapy-power.
* gnu/packages/radio.scm (soapy-power): New variable.
-rw-r--r--gnu/packages/radio.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index cff86389f4..8cc374e4fa 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -488,6 +488,28 @@ controls for certain tuners which may be paired with an audio device.")
library.")
(license license:expat)))
+(define-public soapy-power
+ (package
+ (name "soapy-power")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "soapy_power" version))
+ (sha256
+ (base32 "1rajmygcqvv5ph7yk65r4w581lfszrz0f48csvfmma1ami0lirdm"))))
+ (build-system python-build-system)
+ (inputs
+ (list python-numpy
+ python-scipy
+ python-simplesoapy
+ python-simplespectral))
+ (home-page "https://github.com/xmikos/soapy_power")
+ (synopsis "Obtain power spectrum from SDR devices")
+ (description "The @code{soapy_power} obtains the power spectrum from SDR
+devices that are supported by the SoapySDR library.")
+ (license license:expat)))
+
(define-public aptdec
;; No release since 2013, use commit directly.
(let ((commit "51405971fd4e97714d1e987269e49c6edfe4e0da")