aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-05 08:46:15 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-05 08:46:58 +0000
commit5f1e33f76c1c6eb3d9c90eac9bd94cdacf8bfd2a (patch)
tree565b1b94e4852695cc319806a1aaabe97b2d55e9
parent130232fd8b72a683236091dd769cebb8d605dc9b (diff)
downloadguix-5f1e33f76c1c6eb3d9c90eac9bd94cdacf8bfd2a.tar
guix-5f1e33f76c1c6eb3d9c90eac9bd94cdacf8bfd2a.tar.gz
gnu: hurd: Fix build.
* gnu/packages/hurd.scm (hurd)[configure-flags]: Turn it into a GEXP. Pass the -fcommon flag to fix the build with GCC 10.
-rw-r--r--gnu/packages/hurd.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7a0236c30b..f30192961c 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -508,16 +508,18 @@ exec ${system}/rc \"$@\"
(copy-file "unifont"
(string-append datadir "/vga-system.bdf"))
#t))))
- #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- %output "/lib")
- "--disable-ncursesw"
- "--without-libbz2"
- "--without-libz"
- "--without-parted"
- ;; This is needed to pass the configure check for
- ;; clnt_create
- "ac_func_search_save_LIBS=-ltirpc"
- "ac_cv_search_clnt_create=false")))
+ #:configure-flags
+ ,#~(list (string-append "LDFLAGS=-Wl,-rpath="
+ #$output "/lib")
+ "--disable-ncursesw"
+ "--without-libbz2"
+ "--without-libz"
+ "--without-parted"
+ ;; This is needed to pass the configure check for
+ ;; clnt_create
+ "ac_func_search_save_LIBS=-ltirpc"
+ "ac_cv_search_clnt_create=false"
+ "CFLAGS=-fcommon")))
(build-system gnu-build-system)
(inputs
`(("glibc-hurd-headers" ,glibc/hurd-headers)