aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-09-15 20:36:38 -0300
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 14:18:21 +0000
commit5c4fd77097e2cecfd4780e099af7954f86779fe1 (patch)
treea04414dfc0a56a01daf096c10aa9c52489281d5e
parentcbb76da1f6fd9a27bb1826274493cc6f33000f18 (diff)
downloadguix-5c4fd77097e2cecfd4780e099af7954f86779fe1.tar
guix-5c4fd77097e2cecfd4780e099af7954f86779fe1.tar.gz
etc: Add systemd files for running ‘guix gc’ periodically
* etc/guix-gc.service.in: New file. * etc/guix-gc.timer: Likewise. * .gitignore: Ignore generated ‘guix-gc.service’. * nix/local.mk (nodist_systemdservice_DATA): Add ‘guix-gc.service’ and ‘guix-gc.timer’. (EXTRA_DIST): Add ‘guix-gc.service.in’ and ‘guix-gc.timer’. * doc/guix.texi (Binary Installation): Mention the new systemd files. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--.gitignore1
-rw-r--r--doc/guix.texi12
-rw-r--r--etc/guix-gc.service.in20
-rw-r--r--etc/guix-gc.timer15
-rw-r--r--nix/local.mk6
5 files changed, 53 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 88fe24586d..59e1460fef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -74,6 +74,7 @@
/etc/guix-daemon.service
/etc/guix-publish.conf
/etc/guix-publish.service
+/etc/guix-gc.service
/etc/init.d/guix-daemon
/etc/openrc/guix-daemon
/guix-*
diff --git a/doc/guix.texi b/doc/guix.texi
index 6436e83a7c..cd8e249ae8 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -743,6 +743,18 @@ with these commands:
# systemctl enable --now gnu-store.mount guix-daemon
@end example
+You may also want to arrange for @command{guix gc} to run periodically:
+
+@example
+# cp ~root/.config/guix/current/lib/systemd/system/guix-gc.service \
+ ~root/.config/guix/current/lib/systemd/system/guix-gc.timer \
+ /etc/systemd/system/
+# systemctl enable --now guix-gc.timer
+@end example
+
+You may want to edit @file{guix-gc.service} to adjust the command line
+options to fit your needs (@pxref{Invoking guix gc}).
+
If your host distro uses the Upstart init system:
@example
diff --git a/etc/guix-gc.service.in b/etc/guix-gc.service.in
new file mode 100644
index 0000000000..2f1ca6584b
--- /dev/null
+++ b/etc/guix-gc.service.in
@@ -0,0 +1,20 @@
+# This is a "service unit file" for the systemd init system to perform a
+# one-shot 'guix gc' operation. It is meant to be triggered by a timer.
+# Drop it in /etc/systemd/system or similar together with 'guix-gc.timer'
+# to set it up.
+
+[Unit]
+Description=Discard unused Guix store items
+
+[Service]
+Type=oneshot
+# Customize the 'guix gc' arguments to fit your needs.
+ExecStart=@localstatedir@/guix/profiles/per-user/root/current-guix/bin/guix gc -d 1m -F 10G
+PrivateDevices=yes
+PrivateNetwork=yes
+PrivateUsers=no
+ProtectKernelTunables=yes
+ProtectKernelModules=yes
+ProtectControlGroups=yes
+MemoryDenyWriteExecute=yes
+SystemCallFilter=@default @file-system @basic-io @system-service
diff --git a/etc/guix-gc.timer b/etc/guix-gc.timer
new file mode 100644
index 0000000000..192132fbda
--- /dev/null
+++ b/etc/guix-gc.timer
@@ -0,0 +1,15 @@
+# This is a "timer unit file" for the systemd init system to trigger
+# 'guix-gc.service' periodically. Drop it in /etc/systemd/system or similar
+# together with 'guix-gc.service' to set it up.
+
+[Unit]
+Description=Discard unused Guix store items
+
+[Timer]
+OnCalendar=weekly
+AccuracySec=1h
+Persistent=true
+RandomizedDelaySec=6000
+
+[Install]
+WantedBy=timers.target
diff --git a/nix/local.mk b/nix/local.mk
index 7c438ea78c..d6b4d7faeb 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -153,7 +153,9 @@ systemdservicedir = $(libdir)/systemd/system
nodist_systemdservice_DATA = \
etc/gnu-store.mount \
etc/guix-daemon.service \
- etc/guix-publish.service
+ etc/guix-publish.service \
+ etc/guix-gc.service \
+ etc/guix-gc.timer
etc/%.mount: etc/%.mount.in \
$(top_builddir)/config.status
@@ -216,6 +218,8 @@ EXTRA_DIST += \
etc/guix-daemon.conf.in \
etc/guix-publish.service.in \
etc/guix-publish.conf.in \
+ etc/guix-gc.service.in \
+ etc/guix-gc.timer \
etc/init.d/guix-daemon.in \
etc/openrc/guix-daemon.in