aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2024-02-19 13:21:40 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-03 23:33:38 +0000
commit51387c0f428dce1f5ae7b16a69eaeafea96fd026 (patch)
tree774158bbff0e094e242bc0b4e68c847af0bd1d3e
parent12455b36346f7ff0acf0811d9bddb657aa721075 (diff)
downloadguix-51387c0f428dce1f5ae7b16a69eaeafea96fd026.tar
guix-51387c0f428dce1f5ae7b16a69eaeafea96fd026.tar.gz
gnu: nicotine+: Update to 3.3.0.
* gnu/packages/nicotine.scm (nicotine+): Update to 3.3.0. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I5f34b6de78842e1a90720393b5c84470aba0a8ca
-rw-r--r--gnu/packages/nicotine.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 08232c2756..909adfd3d0 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -34,17 +34,17 @@
(define-public nicotine+
(package
(name "nicotine+")
- (version "3.2.1")
+ (version "3.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Nicotine-Plus/nicotine-plus")
(commit version)))
(file-name (git-file-name name version))
- (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))
+ (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
(modules '((guix build utils)))
;; Remove test that relies on network access.
- (snippet '(delete-file-recursively "test/integration"))))
+ (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
(build-system python-build-system)
(arguments
`(#:imported-modules ((guix build glib-or-gtk-build-system)
@@ -72,7 +72,7 @@
(when tests?
(invoke "xvfb-run" "python" "-m" "unittest")))))))
(inputs
- (list bash-minimal gspell gtk+ python-pygobject libappindicator python-pytaglib))
+ (list bash-minimal gspell gtk python-pygobject libappindicator python-pytaglib))
(native-inputs
(list gettext-minimal xvfb-run))
(home-page "https://nicotine-plus.org/")