aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-18 10:22:11 -0400
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 16:43:17 +0200
commit469e6aaea08d539c8e715c69cdb45f937f068741 (patch)
tree40a37a681583db106447e8a265d98d8be45f56fd
parent389b71aa0f756608236565067f2f77ee1f9390da (diff)
downloadguix-469e6aaea08d539c8e715c69cdb45f937f068741.tar
guix-469e6aaea08d539c8e715c69cdb45f937f068741.tar.gz
gnu: Add cxxopts.
* gnu/packages/cpp.scm (cxxopts): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/cpp.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 003883e1a5..90e139e9eb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -647,3 +648,24 @@ Google's C++ code base.")
a zero-dependency C++ header-only parser combinator library for creating
parsers according to a Parsing Expression Grammar (PEG).")
(license license:expat)))
+
+(define-public cxxopts
+ (package
+ (name "cxxopts")
+ (version "2.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jarro2783/cxxopts")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d3y747lsh1wkalc39nxd088rbypxigm991lk3j91zpn56whrpha"))))
+ (build-system cmake-build-system)
+ (synopsis "Lightweight C++ command line option parser")
+ (description
+ "A lightweight header-only C++ option parser library, supporting the
+standard GNU style syntax for options.")
+ (home-page "https://github.com/jarro2783/cxxopts/wiki")
+ (license license:expat)))