aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-15 10:39:30 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-17 08:47:10 +0100
commit36cbd2654e6e4685128d9fb457037c16f934836b (patch)
treedf9abfafed2ceeebede6ae324d991679f6786081
parent3755941f038ec66fba568fa88d6b2d295e196723 (diff)
downloadguix-36cbd2654e6e4685128d9fb457037c16f934836b.tar
guix-36cbd2654e6e4685128d9fb457037c16f934836b.tar.gz
gnu: ghc-8.10: Fix build on i686-linux.
As one profiling test fails very repeatedly on the bordeaux build farm, but ghc did seem to build successfully on other machines. * gnu/packages/haskell.scm (ghc-8.10)[arguments]: Don't run the T11627a profiling test on i686-linux.
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b2c86fec4..62815efbb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1271,8 +1271,11 @@ interactive environment for the functional language Haskell.")
;; next rebuild. Note that they are required for GHC 8.10 and 9.2.
#$@(if (string-prefix? "i686" (or (%current-target-system)
(%current-system)))
- #~((add-after 'skip-failing-tests-i686 'skip-failing-tests-i686-cuirass
+ #~((add-after 'skip-failing-tests-i686 'skip-more-failing-tests-i686
(lambda _
+ (substitute* '("testsuite/tests/profiling/should_run/all.T")
+ (("test\\('T11627a', \\[ ")
+ "test('T11627a', [ when(arch('i386'), skip), "))
(substitute* '("testsuite/driver/testlib.py")
((".*changes being made to the file will invalidate the code signature.*")
"")