aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 12:20:09 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit3533db28ced3034898c4a1c58c4a8a50e35228a7 (patch)
tree205e313580557bf14d3f2bf798c0c6c861a05e4a
parent66b6d6a9301a70540c434f3fbd2567ff28bedcff (diff)
downloadguix-3533db28ced3034898c4a1c58c4a8a50e35228a7.tar
guix-3533db28ced3034898c4a1c58c4a8a50e35228a7.tar.gz
gnu: python-hypothesis: Update to 6.54.5.
* gnu/packages/check.scm (python-hypothesis): Update to 6.54.5. [arguments]: Disable sanity check. [propagated-inputs]: Add PYTHON-EXCEPTIONGROUP. (python-hypothesis-next): Deprecate. * gnu/packages/matrix.scm (python-matrix-nio)[native-inputs]: Change from PYTHON-HYPOTHESIS-NEXT to PYTHON-HYPOTHESIS. * gnu/packages/python-web.scm (python-h2)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-numpy, python-cattrs)[native-inputs]: Likewise.
-rw-r--r--gnu/packages/check.scm31
-rw-r--r--gnu/packages/matrix.scm2
-rw-r--r--gnu/packages/python-web.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
4 files changed, 16 insertions, 23 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 556198269b..b767be6552 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -89,6 +89,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix deprecation)
#:use-module (srfi srfi-1))
(define-public pict
@@ -1997,20 +1998,24 @@ instantly.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "6.0.2")
+ (version "6.54.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0wj7ip779naf2n076nylf2gi0sjz68z1ir9d9r2rgs7br18naqdf"))))
+ "1ivyrjpnahvj359pfndnk8x3h0gw37kqm02fmnzibx4mas15d44a"))))
(build-system python-build-system)
(arguments
;; XXX: Tests are not distributed with the PyPI archive.
- '(#:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: hypothesis requires pytest at runtime, but we can
+ ;; not propagate it due to a circular dependency.
+ (delete 'sanity-check))))
(propagated-inputs
- `(("python-attrs" ,python-attrs-bootstrap)
- ("python-sortedcontainers" ,python-sortedcontainers)))
+ (list python-attrs-bootstrap python-exceptiongroup python-sortedcontainers))
(synopsis "Library for property based testing")
(description "Hypothesis is a library for testing your Python code against a
much larger range of examples than you would ever want to write by hand. It’s
@@ -2019,20 +2024,8 @@ seamlessly into your existing Python unit testing work flow.")
(home-page "https://github.com/HypothesisWorks/hypothesis")
(license license:mpl2.0)))
-;;; TODO: Make the default python-hypothesis in the next rebuild cycle.
-(define-public python-hypothesis-next
- (package
- (inherit python-hypothesis)
- (version "6.43.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "hypothesis" version))
- (sha256
- (base32
- "0d67dlc5a47i48fxzmji2mnybzby0h1wdscmj54555fghcyp1045"))))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-hypothesis)
- (append python-pytest))))) ;to satisfy the sanity-check phase
+(define-deprecated python-hypothesis-next python-hypothesis)
+(export python-hypothesis-next)
(define-public python-hypothesmith
(package
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 2ba6d8ba1f..6604226f47 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -187,7 +187,7 @@ homeserver and generally help bootstrap the ecosystem.")
(native-inputs
`(("python-pytest" ,python-pytest-6)
("python-hyperframe" ,python-hyperframe)
- ("python-hypothesis" ,python-hypothesis-next)
+ ("python-hypothesis" ,python-hypothesis)
("python-hpack" ,python-hpack)
("python-faker" ,python-faker)
("python-pytest-aiohttp" ,python-pytest-aiohttp)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6ae6673ad3..d2bfe29b6f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1203,7 +1203,7 @@ and that could be anything you want.")
(add-installed-pythonpath inputs outputs)
(invoke "python" "-m" "pytest" "-vv" "test")))))))
(native-inputs
- (list python-hypothesis-next python-pytest))
+ (list python-hypothesis python-pytest))
(propagated-inputs
(list python-hpack python-hyperframe))
(home-page "https://github.com/python-hyper/h2")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index da025f6692..fe344123f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5686,7 +5686,7 @@ include_dirs = ~:*~a/include~%"
'())))))))))
(native-inputs
(list python-cython
- python-hypothesis-next
+ python-hypothesis
python-pytest
python-pytest-xdist
python-typing-extensions
@@ -16855,7 +16855,7 @@ strings require only one extra byte in addition to the strings themselves.")
;; build system and new Rust dependencies.
"--ignore" "tests/test_preconf.py")))))))
(native-inputs
- (list python-hypothesis-next
+ (list python-hypothesis
python-immutables
python-msgpack
python-poetry-core