aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-14 10:24:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:21 +0200
commit30ae3f1d929cfa66e6b946817089a4c448c3e98a (patch)
treefa66b03116d0764c97b2ba0a8028b25fa237fe98
parent8fc17cf91c45fa907a54c13b0bc43c07cdce78f5 (diff)
downloadguix-30ae3f1d929cfa66e6b946817089a4c448c3e98a.tar
guix-30ae3f1d929cfa66e6b946817089a4c448c3e98a.tar.gz
gnu: Add rust-objc2-symbols-0.2.
* gnu/packages/crates-apple.scm (rust-objc2-symbols-0.2): New variable. Change-Id: I86fae2ca460966b2104b9433dfdfae21b9a603f8
-rw-r--r--gnu/packages/crates-apple.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index fd62d1c34c..8d450b33aa 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -1517,6 +1517,28 @@ the Cocoa Foundation framework.")
(description "This package provides procedural macros for the objc2 project.")
(license license:expat)))
+(define-public rust-objc2-symbols-0.2
+ (package
+ (name "rust-objc2-symbols")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "objc2-symbols" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1p04hjkxan18g2b7h9n2n8xxsvazapv2h6mfmmdk06zc7pz4ws0a"))))
+ (build-system cargo-build-system)
+ (arguments
+ ;; Must specify the desired runtime using Cargo features on non-Apple platforms
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-objc2" ,rust-objc2-0.5)
+ ("rust-objc2-foundation" ,rust-objc2-foundation-0.2))))
+ (home-page "https://github.com/madsmtm/objc2")
+ (synopsis "Bindings to the Symbols framework")
+ (description "This package Provides Bindings to the Symbols framework.")
+ (license license:expat)))
+
(define-public rust-objc2-uniform-type-identifiers-0.2
(package
(name "rust-objc2-uniform-type-identifiers")