aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-04-14 16:18:51 +0900
committerFlorian Pelz <pelzflorian@pelzflorian.de>2024-06-03 00:27:11 +0200
commit2d4af5247057505956e841d396ec78af9f769837 (patch)
tree591b2b9b9518f75376527ac2487d3bc5b00be93d
parent77c79bf5daff2e8041453b7a7112656d6409264b (diff)
downloadguix-2d4af5247057505956e841d396ec78af9f769837.tar
guix-2d4af5247057505956e841d396ec78af9f769837.tar.gz
build: Update the POT creation task with the po4a command.
* configure.ac (Documentation translation): Add the po4a program and remove the po4a-updatepo program. The PO4A defined here can be used in Makefiles (e.g. po/doc/local.mk below). The po4a command integrates the functionality of po4a-updatepo and is currently recommended for use [1]. The po4a-updatepo command has been replaced by the po4a command and are not used from anywhere. * po/doc/local.mk (%D%/%.pot): Use a po4a command instead of the po4a-updatepo for the POT generation. This eliminates the warning of po4a-updatepo; "po4a-updatepo is deprecated. The unified po4a(1) program is more convenient and less error prone." Here, the file paths are passed using variables. This is because the po4a command needs to be executed for each language and each file. Dummy values are passed for those that are not needed to update the POT file. * po/doc/po4a.cfg: Add a po4a config file for the POT generation. The po4a command requires a configulation file. [1] https://po4a.org/man/man7/po4a.7.php.en#lbAS Change-Id: Ica39a0d1f77b6a64d37c592ac2e693319443d3c5 Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de>
-rw-r--r--configure.ac2
-rw-r--r--po/doc/local.mk10
-rw-r--r--po/doc/po4a.cfg32
3 files changed, 41 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c7b61d56a7..7ef135c0a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,8 +264,8 @@ dnl Manual pages.
AM_MISSING_PROG([HELP2MAN], [help2man])
dnl Documentation translation.
+AM_MISSING_PROG([PO4A], [po4a])
AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
-AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
AC_MSG_CHECKING([if building from git])
if test -e .git; then
diff --git a/po/doc/local.mk b/po/doc/local.mk
index 77ec4721e3..419898a139 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -2,6 +2,7 @@
# Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
# Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -45,8 +46,13 @@ POT_OPTIONS = \
--msgid-bugs-address "bug-guix@gnu.org"
%D%/%.pot: $(srcdir)/doc/%.texi
- $(AM_V_PO4A)$(PO4A_UPDATEPO) -M UTF-8 -f texinfo -m "$<" \
- -p "$@-t" $(POT_OPTIONS)
+ $(AM_V_PO4A)$(PO4A) --no-translations -M UTF-8 \
+ --package-version "$(VERSION)" \
+ --variable master="$<" \
+ --variable pot="$@-t" \
+ --variable po=/dev/null \
+ --variable localized=/dev/null \
+ $(POT_OPTIONS) %D%/po4a.cfg
date="$$(git log --pretty=format:%ci -n 1 -- $< 2>/dev/null \
|| echo $(SOURCE_DATE_EPOCH))" \
sed -ri -e "s,^(.POT-Creation-Date: )[^\]*,\1$$date," "$@-t"
diff --git a/po/doc/po4a.cfg b/po/doc/po4a.cfg
new file mode 100644
index 0000000000..7d2ef71773
--- /dev/null
+++ b/po/doc/po4a.cfg
@@ -0,0 +1,32 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+# "--keep 0": produce an output even if the translation is not complete
+[options] \
+ --package-name "guix manual" \
+ --copyright-holder "the authors of Guix (msgids)" \
+ --msgid-bugs-address "bug-guix@gnu.org" \
+ --master-charset UTF-8 \
+ --localized-charset UTF-8 \
+ --keep 0
+
+[po4a_langs] de es fr pt_BR ru zh_CN ko sk
+
+[po4a_paths] $(pot) $lang:$(po)
+
+[type:texinfo] $(master) $lang:$(localized)