aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-10 19:50:42 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 16:18:35 +0200
commit2104efcddfd7649839673886ec44f77dcd5b5041 (patch)
treef0a3cba78fef7f19141e3f144a019c01ee8a92b2
parent50108016764dcb4f1e328ab24c9df6c5710ccb61 (diff)
downloadguix-2104efcddfd7649839673886ec44f77dcd5b5041.tar
guix-2104efcddfd7649839673886ec44f77dcd5b5041.tar.gz
gnu: Explicitly use OpenSSL 1.1 in packages that don't support 3.0.
* gnu/packages/php.scm (php)[inputs]: Change from OPENSSL to OPENSSL-1.1. * gnu/packages/ntp.scm (ntp)[inputs]: Likewise.
-rw-r--r--gnu/packages/ntp.scm2
-rw-r--r--gnu/packages/php.scm2
2 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index b942703ff3..a27c1c6a12 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -155,7 +155,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
#t))))
(native-inputs (list which pkg-config))
(inputs
- `(("openssl" ,openssl)
+ `(("openssl" ,openssl-1.1)
("libevent" ,libevent)
;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
;; to run as non-root (when invoked with '-u'.)
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index fdea27160d..645a8edee1 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -381,7 +381,7 @@
("libzip" ,libzip)
("oniguruma" ,oniguruma)
("openldap" ,openldap)
- ("openssl" ,openssl)
+ ("openssl" ,openssl-1.1)
("pcre" ,pcre2)
("postgresql" ,postgresql)
("readline" ,readline)