aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Vilata-i-Balaguer <ivan@selidor.net>2024-04-06 11:24:50 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-07 19:36:51 +0100
commit1acd3cdc9e18ae1b2994263d738c309166df919a (patch)
tree1ef620afba7cb67d624de6d18a63b166c4d3e9d8
parentacd3cb258fe68548b3c14b3b7819a46e2cd2da97 (diff)
downloadguix-1acd3cdc9e18ae1b2994263d738c309166df919a.tar
guix-1acd3cdc9e18ae1b2994263d738c309166df919a.tar.gz
gnu: Add xssstate.
* gnu/packages/suckless.scm (xssstate): New variable. Reviewed-by: Steve George <steve@futurile.net> Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: I80a44b979ae987b953dcbdb3979b9b4ad8e30c79
-rw-r--r--gnu/packages/suckless.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index a907b2fc6b..39cf2e4cc5 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2022 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2024 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 cage <cage-dev@twistfold.it>
@@ -1361,6 +1362,35 @@ It also contains the Plan 9 libbio, libregexp, libfmt and libutf libraries.")
(license (list license:expat ;modifications
license:lpl1.02))))) ;original plan9 code
+(define-public xssstate
+ (package
+ (name "xssstate")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.suckless.org/tools/xssstate-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04b03jz38pn5qhddg8a9hh01qqzrrdjvsq09qrxj9sx8lq2gbdn4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list libxscrnsaver))
+ (home-page "https://tools.suckless.org/x/xssstate/")
+ (synopsis "Simple tool to retrieve the X screensaver state")
+ (description
+ "A utility to retrieve the state of the X screensaver. These
+states include the idle time, the screensaver state and the length of time
+until the screensaver should be activated.")
+ (license license:x11)))
+
(define-public 9yacc
(package
(inherit lib9)