aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-21 22:16:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-21 22:19:33 +0200
commit1a1ff7ed8fdaae58aff0e8625399cd7354038ca3 (patch)
treea0d161b7783ee9b9b6f489243003cd5da6793845
parentcd5bbb9b4227a29bc954db7de2e8d76b9d24bd67 (diff)
downloadguix-1a1ff7ed8fdaae58aff0e8625399cd7354038ca3.tar
guix-1a1ff7ed8fdaae58aff0e8625399cd7354038ca3.tar.gz
gnu: python-cooler: Skip broken test.
* gnu/packages/bioinformatics.scm (python-cooler)[arguments]: Add another patch for tests/test_util.py.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fb4d93769e..5015069a1d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12750,10 +12750,13 @@ fasta subsequences.")
"access to genome.ucsc.edu\")\n"
"def test_roundtrip")))
(substitute* "tests/test_util.py"
- (("def test_fetch_chromsizes")
- (string-append "@pytest.mark.skip(reason=\"requires network "
- "access to genome.ucsc.edu\")\n"
- "def test_fetch_chromsizes")))
+ (("def test_fetch_chromsizes")
+ (string-append "@pytest.mark.skip(reason=\"requires network "
+ "access to genome.ucsc.edu\")\n"
+ "def test_fetch_chromsizes"))
+ ;; See https://github.com/open2c/cooler/issues/287
+ (("skipif\\(six.PY2, reason=\"Scipy on Py2 is too old\"")
+ "skip(reason=\"Scipy is too new\""))
;; This test depends on ipytree, which contains a lot of minified
;; JavaScript.
(substitute* "tests/test_fileops.py"