aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-10-27 14:05:52 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-11-20 17:00:27 +0100
commit17d9a91e6b8bdd7709b536d34a1f2ef3fcff3b9d (patch)
tree5cbb6bb27cf5069424a00dcae49655703faccc48
parent924d082692f4d442f52fc9b540379f350a5ce118 (diff)
downloadguix-17d9a91e6b8bdd7709b536d34a1f2ef3fcff3b9d.tar
guix-17d9a91e6b8bdd7709b536d34a1f2ef3fcff3b9d.tar.gz
image: Add pinebook-pro support.
* gnu/system/images/pinebook-pro.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/ci.scm (%guix-system-images): Add pinebook-pro-barebones-raw-image.
-rw-r--r--gnu/ci.scm4
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/system/images/pinebook-pro.scm66
3 files changed, 70 insertions, 1 deletions
diff --git a/gnu/ci.scm b/gnu/ci.scm
index bf9952a450..a5afef91ae 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -57,6 +57,7 @@
#:use-module (gnu system install)
#:use-module (gnu system images hurd)
#:use-module (gnu system images pine64)
+ #:use-module (gnu system images pinebook-pro)
#:use-module (gnu tests)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
@@ -205,7 +206,8 @@ SYSTEM."
(define %guix-system-images
(list hurd-barebones-qcow2-image
- pine64-barebones-raw-image))
+ pine64-barebones-raw-image
+ pinebook-pro-barebones-raw-image))
(define (image-jobs store system)
"Return a list of jobs that build images for SYSTEM."
diff --git a/gnu/local.mk b/gnu/local.mk
index e728ed28d1..35369063f1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -652,6 +652,7 @@ GNU_SYSTEM_MODULES = \
\
%D%/system/images/hurd.scm \
%D%/system/images/pine64.scm \
+ %D%/system/images/pinebook-pro.scm \
\
%D%/machine.scm \
\
diff --git a/gnu/system/images/pinebook-pro.scm b/gnu/system/images/pinebook-pro.scm
new file mode 100644
index 0000000000..b038e262cb
--- /dev/null
+++ b/gnu/system/images/pinebook-pro.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images pinebook-pro)
+ #:use-module (gnu bootloader)
+ #:use-module (gnu bootloader u-boot)
+ #:use-module (gnu image)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu services)
+ #:use-module (gnu services base)
+ #:use-module (gnu system)
+ #:use-module (gnu system file-systems)
+ #:use-module (gnu system image)
+ #:use-module (srfi srfi-26)
+ #:export (pinebook-pro-barebones-os
+ pinebook-pro-image-type
+ pinebook-pro-barebones-raw-image))
+
+(define pinebook-pro-barebones-os
+ (operating-system
+ (host-name "viso")
+ (timezone "Europe/Paris")
+ (locale "en_US.utf8")
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-pinebook-pro-rk3399-bootloader)
+ (target "/dev/vda")))
+ (initrd-modules '())
+ (kernel linux-libre-arm64-generic)
+ (file-systems (cons (file-system
+ (device (file-system-label "my-root"))
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+ (services (cons (service agetty-service-type
+ (agetty-configuration
+ (extra-options '("-L")) ; no carrier detect
+ (baud-rate "115200")
+ (term "vt100")
+ (tty "ttyS0")))
+ %base-services))))
+
+(define pinebook-pro-image-type
+ (image-type
+ (name 'pinebook-pro-raw)
+ (constructor (cut image-with-os arm64-disk-image <>))))
+
+(define pinebook-pro-barebones-raw-image
+ (image
+ (inherit
+ (os->image pinebook-pro-barebones-os #:type pinebook-pro-image-type))
+ (name 'pinebook-pro-barebones-raw-image)))