aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGarek Dyszel <garekdyszel@disroot.org>2022-09-07 14:33:55 -0400
committerJulien Lepiller <julien@lepiller.eu>2022-09-24 20:24:49 +0200
commit142cccef63651a50348c611790ebe22ec343676e (patch)
treebcf4e2aa93cbb4984ba721ca452ad928341536d9
parent501072af869b1bab87d8c292788854176fa58272 (diff)
downloadguix-142cccef63651a50348c611790ebe22ec343676e.tar
guix-142cccef63651a50348c611790ebe22ec343676e.tar.gz
gnu: Add python-version.
* gnu/packages/python-xyz.scm (python-version): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92e0c9dbe8..c41e7dbf5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -129,6 +129,7 @@
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
+;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27167,6 +27168,29 @@ applications with variable CPU loads).")
(home-page "https://jwilk.net/software/python-djvulibre")
(license license:gpl2)))
+(define-public python-version
+ ;; No version tags available in the git repo; just using bare commit instead.
+ (let ((commit "5232eea250ab72cc5cb72b0b75efb35d2192b906")
+ (revision "1"))
+ (package
+ (name "python-version")
+ (version (git-version "0.0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/halfak/python_version")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w210559ypdynlj9yn40m9awzkaknwrf682i99hswl7h66sdgh0h"))))
+ (build-system python-build-system)
+ (home-page "https://gitlab.com/halfak/python_version")
+ (synopsis "Python version checking utility")
+ (description
+ "This package provides a simple utility for checking the python version.")
+ (license license:expat))))
+
(define-public python-versioneer
(package
(name "python-versioneer")