aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-26 21:51:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 10:05:53 -0400
commit068dfa33dede9caf35fbb339fe7290e0d8b4c619 (patch)
tree3d35f30c7c778258544244b1aad15facb0e06db3
parent26dd4ce571636e2e59c756d780cb2cfa7ed20d6d (diff)
downloadguix-068dfa33dede9caf35fbb339fe7290e0d8b4c619.tar
guix-068dfa33dede9caf35fbb339fe7290e0d8b4c619.tar.gz
gnu: openjdk14: Define with make-openjdk.
* gnu/packages/java.scm (openjdk14): Define with make-openjdk. [source]: Remove trailing #t from snippet field and improve regexp.
-rw-r--r--gnu/packages/java.scm58
1 files changed, 12 insertions, 46 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f32ff47254..6fc5500ba2 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2117,52 +2117,18 @@ blacklisted.certs.pem"
"0wrrr0d7lz1v8qqm752mn4gz5l2vpl2kmx4ac3ysvk4mljc924hp"))
(define-public openjdk14
- (package
- (inherit openjdk13)
- (name "openjdk")
- (version "14.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/openjdk/jdk14u")
- (commit (string-append "jdk-" version "-ga"))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07k9bsbxwyf2z2n50z96nvhsdai916mxdxcr5lm44jz7f6xrwfq6"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- ;; The m4 macro uses 'help' to search for builtins, which is
- ;; not available in bash-minimal
- (substitute* "make/autoconf/basics.m4"
- (("if help") "if command -v"))
- (for-each delete-file (find-files "." ".*.(bin|exe|jar)$"))
- #t))))
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("cups" ,cups)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("giflib" ,giflib)
- ("lcms" ,lcms)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxrandr" ,libxrandr)
- ("libxrender" ,libxrender)
- ("libxt" ,libxt)
- ("libxtst" ,libxtst)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("make@4.2" ,gnu-make-4.2)
- ("openjdk13:jdk" ,openjdk13 "jdk")
- ("pkg-config" ,pkg-config)
- ("unzip" ,unzip)
- ("which" ,which)
- ("zip" ,zip)))
- (home-page "https://openjdk.java.net/projects/jdk/14")))
+ (make-openjdk
+ openjdk13 "14.0.2"
+ "07k9bsbxwyf2z2n50z96nvhsdai916mxdxcr5lm44jz7f6xrwfq6"
+ (source (origin
+ (inherit (package-source base))
+ (snippet ;override snippet
+ '(begin
+ ;; The m4 macro uses 'help' to search for builtins, which is
+ ;; not available in bash-minimal
+ (substitute* "make/autoconf/basics.m4"
+ (("if help") "if command -v"))
+ (for-each delete-file (find-files "." "\\.(bin|exe|jar)$"))))))))
(define-public openjdk15
(package