aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-12-09 12:20:48 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-12-09 12:20:48 +0100
commit02b6382169192367e97a2d1bc72f8eb3ed38b0dc (patch)
tree1049568a04f60a26d5a93cb018a8cb526a14843b
parent0bfa8744ae7f085416da15b234dcfdfa08c3b104 (diff)
downloadguix-02b6382169192367e97a2d1bc72f8eb3ed38b0dc.tar
guix-02b6382169192367e97a2d1bc72f8eb3ed38b0dc.tar.gz
gnu: sbcl: Fix missing return value of phase.
* gnu/packages/lisp.scm (sbcl)[arguments]: Return #t in patch-unix-tool-paths phase.
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index dc44a9d133..d51b9a3662 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
@@ -354,10 +354,10 @@ an interpreter, a compiler, a debugger, and much more.")
;;
;; CCL is not bootstrappable so it won't do. CLISP 2.49 seems to work.
;; ECL too. ECL builds SBCL about 20% slower than CLISP. As of
- ;; 2019-09-05, ECL was last updated in 2016 while CLISP was last update
+ ;; 2019-09-05, ECL was last updated in 2016 while CLISP was last updated
;; in 2010.
;;
- ;; For now we stick to CLISP for all systems. We keep the `match' in to
+ ;; For now we stick to CLISP for all systems. We keep the `match' here to
;; make it easier to change the host compiler for various architectures.
`(,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
@@ -422,7 +422,8 @@ an interpreter, a compiler, a debugger, and much more.")
(("\\(deftest pwent\\.[12]" all)
(string-append "#+nil ;disabled by Guix\n" all))
(("\\(deftest grent\\.[12]" all)
- (string-append "#+nil ;disabled by Guix\n" all))))))
+ (string-append "#+nil ;disabled by Guix\n" all))))
+ #t))
;; FIXME: the texlive-union insists on regenerating fonts. It stores
;; them in HOME, so it needs to be writeable.
(add-before 'build 'set-HOME
@@ -444,6 +445,7 @@ an interpreter, a compiler, a debugger, and much more.")
(invoke "sh" "install.sh")))
(add-after 'build 'build-doc
(lambda _
+ ;; TODO: Doc is not deterministic, maybe there is a timespamp?
(with-directory-excursion "doc/manual"
(and (invoke "make" "info")
(invoke "make" "dist")))))