aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-05 20:03:54 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-05 21:22:43 +0000
commita64ccb61e0e250b0994e247bf2d8ba2e932dfb23 (patch)
tree3056034d5b9513e33cc12d089b9553d6b1d3f065
parent17cfb7aeffaaba70e67e9afb50d7100614ffca7f (diff)
downloadguix-upgrade-python-to-3.7.1.tar
guix-upgrade-python-to-3.7.1.tar.gz
gnu: python: Update to 3.7.1.upgrade-python-to-3.7.1
Remove the replacement, as version 3.7.1 includes the fix for this issue. * gnu/packages/python.scm (python-3.7): Update to 3.7.1. (python-3/fixed): Remove this.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d0401b7bdd..1abf2e816c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -343,8 +343,7 @@ data types.")
(define-public python-3.7
(package (inherit python-2)
(name "python")
- (version "3.7.0")
- (replacement python-3/fixed)
+ (version "3.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
@@ -357,7 +356,7 @@ data types.")
(patch-flags '("-p0"))
(sha256
(base32
- "0j9mic5c9lbd2b20wka7hily7szz740wy9ilfrczxap63rnrk0h3"))
+ "0v9x4h22rh5cwpsq1mwpdi3c9lc9820lzp2nmn9g20llij72nzps"))
(snippet
'(begin
(for-each delete-file
@@ -416,14 +415,6 @@ data types.")
;; Current 3.x version.
(define-public python-3 python-3.7)
-(define python-3/fixed
- (package
- (inherit python-3)
- (source (origin
- (inherit (package-source python-3))
- (patches (append (origin-patches (package-source python-3))
- (search-patches "python-CVE-2018-14647.patch")))))))
-
;; Current major version.
(define-public python python-3)