diff options
author | Christopher Baines <mail@cbaines.net> | 2020-04-03 22:25:17 +0100 |
---|---|---|
committer | Christopher Baines <mail@cbaines.net> | 2020-04-04 10:29:25 +0100 |
commit | 7191e80767217280ca0d14012b661d99a393b117 (patch) | |
tree | ab2ddfed1ed0edabee411137bf66e731168d07c2 | |
parent | 8dc5e0eaca7b567c98caa2a8a4537b5acf2d691f (diff) | |
download | build-coordinator-7191e80767217280ca0d14012b661d99a393b117.tar build-coordinator-7191e80767217280ca0d14012b661d99a393b117.tar.gz |
Add some empty scripts
-rw-r--r-- | .gitignore | 3 | ||||
-rw-r--r-- | configure.ac | 8 | ||||
-rw-r--r-- | scripts/guix-build-coordinator-agent.in | 24 | ||||
-rw-r--r-- | scripts/guix-build-coordinator.in | 24 |
4 files changed, 59 insertions, 0 deletions
@@ -17,3 +17,6 @@ tests/*.trs pre-inst-env .local.envrc + +scripts/guix-build-coordinator +scripts/guix-build-coordinator-agent diff --git a/configure.ac b/configure.ac index e60e922..47c7f6a 100644 --- a/configure.ac +++ b/configure.ac @@ -10,5 +10,13 @@ fi AC_CONFIG_FILES([Makefile]) AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env]) +AC_CONFIG_FILES( + [scripts/guix-build-coordinator], + [chmod +x scripts/guix-build-coordinator] +) +AC_CONFIG_FILES( + [scripts/guix-build-coordinator-agent], + [chmod +x scripts/guix-build-coordinator-agent] +) AC_OUTPUT diff --git a/scripts/guix-build-coordinator-agent.in b/scripts/guix-build-coordinator-agent.in new file mode 100644 index 0000000..e79f218 --- /dev/null +++ b/scripts/guix-build-coordinator-agent.in @@ -0,0 +1,24 @@ +#!@GUILE@ --no-auto-compile +-*- scheme -*- +-*- geiser-scheme-implementation: guile -*- +!# +;;; Guix Build Coordinator +;;; +;;; Copyright © 2020 Christopher Baines <mail@cbaines.net> +;;; +;;; This file is part of the guix-build-coordinator. +;;; +;;; guix-data-service is free software; you can redistribute it and/or modify it +;;; under the terms of the GNU General Public License as published by +;;; the Free Software Foundation; either version 3 of the License, or +;;; (at your option) any later version. +;;; +;;; guix-data-service is distributed in the hope that it will be useful, but +;;; WITHOUT ANY WARRANTY; without even the implied warranty of +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU +;;; General Public License for more details. +;;; +;;; You should have received a copy of the GNU General Public License +;;; along with the guix-data-service. If not, see +;;; <http://www.gnu.org/licenses/>. + diff --git a/scripts/guix-build-coordinator.in b/scripts/guix-build-coordinator.in new file mode 100644 index 0000000..349073c --- /dev/null +++ b/scripts/guix-build-coordinator.in @@ -0,0 +1,24 @@ +#!@GUILE@ --no-auto-compile +-*- scheme -*- +-*- geiser-scheme-implementation: guile -*- +!# +;;; Guix Build Coordinator +;;; +;;; Copyright © 2020 Christopher Baines <mail@cbaines.net> +;;; +;;; This file is part of the guix-build-coordinator. +;;; +;;; The Guix Build Coordinator is free software; you can redistribute +;;; it and/or modify it under the terms of the GNU General Public +;;; License as published by the Free Software Foundation; either +;;; version 3 of the License, or (at your option) any later version. +;;; +;;; The Guix Build Coordinator is distributed in the hope that it will +;;; be useful, but WITHOUT ANY WARRANTY; without even the implied +;;; warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. +;;; See the GNU General Public License for more details. +;;; +;;; You should have received a copy of the GNU General Public License +;;; along with the guix-data-service. If not, see +;;; <http://www.gnu.org/licenses/>. + |