diff options
author | Christopher Baines <mail@cbaines.net> | 2020-04-04 10:31:34 +0100 |
---|---|---|
committer | Christopher Baines <mail@cbaines.net> | 2020-04-04 10:31:34 +0100 |
commit | 63be42a3b477f3c4822d75ee5923118250713214 (patch) | |
tree | 2526755190b3d34e6b381d18773e62130d0e288a | |
parent | ab8ae7a64eab6c794563a3b5782e8912d9f67d1c (diff) | |
download | build-coordinator-63be42a3b477f3c4822d75ee5923118250713214.tar build-coordinator-63be42a3b477f3c4822d75ee5923118250713214.tar.gz |
Add a config.scm file
-rw-r--r-- | .gitignore | 2 | ||||
-rw-r--r-- | Makefile.am | 8 | ||||
-rw-r--r-- | configure.ac | 1 | ||||
-rw-r--r-- | guix-build-coordinator/config.scm.in | 44 |
4 files changed, 53 insertions, 2 deletions
@@ -20,3 +20,5 @@ pre-inst-env scripts/guix-build-coordinator scripts/guix-build-coordinator-agent + +guix-build-coordinator/config.scm diff --git a/Makefile.am b/Makefile.am index c0ecfd7..e4e4509 100644 --- a/Makefile.am +++ b/Makefile.am @@ -1,5 +1,9 @@ include guile.am -SOURCES = \ - guix-build-coordinator/agent.scm +bin_SCRIPTS = \ + scripts/guix-build-coordinator \ + scripts/guix-build-coordinator-agent +SOURCES = \ + guix-build-coordinator/agent.scm \ + guix-build-coordinator/config.scm diff --git a/configure.ac b/configure.ac index 47c7f6a..92b5d2c 100644 --- a/configure.ac +++ b/configure.ac @@ -10,6 +10,7 @@ fi AC_CONFIG_FILES([Makefile]) AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env]) +AC_CONFIG_FILES([guix-build-coordinator/config.scm]) AC_CONFIG_FILES( [scripts/guix-build-coordinator], [chmod +x scripts/guix-build-coordinator] diff --git a/guix-build-coordinator/config.scm.in b/guix-build-coordinator/config.scm.in new file mode 100644 index 0000000..09a86bc --- /dev/null +++ b/guix-build-coordinator/config.scm.in @@ -0,0 +1,44 @@ +;;; Guix Build Coordinator +;;; +;;; Copyright © 2020 Christopher Baines <mail@cbaines.net> +;;; +;;; This program is free software: you can redistribute it and/or +;;; modify it under the terms of the GNU Affero General Public License +;;; as published by the Free Software Foundation, either version 3 of +;;; the License, or (at your option) any later version. +;;; +;;; This program is distributed in the hope that it will be useful, +;;; but WITHOUT ANY WARRANTY; without even the implied warranty of +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU +;;; Affero General Public License for more details. +;;; +;;; You should have received a copy of the GNU Affero General Public +;;; License along with this program. If not, see +;;; <http://www.gnu.org/licenses/>. + +(define-module (guix-build-coordinator config) + #:use-module (guix store) + #:export (%config + + %show-error-details)) + +(define %config + (let ((config + `((guix . "@guix@") + + (sqitch . "@sqitch@") + (sqitch-psql . "@psql@") + (sqitch-plan + . ,(let ((installed-plan + "@prefix@/share/guix-build-coordinator/sqitch/sqitch.plan") + (dev-plan + (string-append (getcwd) "/sqitch/sqitch.plan"))) + (if (file-exists? installed-plan) + installed-plan + dev-plan)))))) + (lambda (key) + (assoc-ref config key)))) + +(define %show-error-details + (make-parameter #f)) + |