aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4810d2538..e7e789620 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,4 +1,4 @@
-asciidoc_files = tor-gencert
+asciidoc_files = tor-gencert torify
html_in = $(asciidoc_files:=.html.in)
@@ -8,9 +8,9 @@ EXTRA_DIST = HACKING \
tor-resolve.1 \
$(html_in) $(man_in) $(asciidoc_files:=.1.txt) \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
- tor-win32-mingw-creation.txt torify.1
+ tor-win32-mingw-creation.txt
-nodist_man_MANS = tor.1 tor-resolve.1 torify.1 $(asciidoc_files:=.1)
+nodist_man_MANS = tor.1 tor-resolve.1 $(asciidoc_files:=.1)
doc_DATA = $(asciidoc_files:=.html)
@@ -25,6 +25,7 @@ DIST_SUBDIRS = design-paper spec
$(html_in) :
$(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+torify.html.in : torify.1.txt
tor-gencert.html.in : tor-gencert.1.txt
# Generate the manpage from asciidoc, but don't do
@@ -32,6 +33,7 @@ tor-gencert.html.in : tor-gencert.1.txt
$(man_in) :
$(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+torify.1.in : torify.1.txt
tor-gencert.1.in : tor-gencert.1.txt
# use ../config.status to swap all machine-specific magic strings
@@ -39,5 +41,7 @@ tor-gencert.1.in : tor-gencert.1.txt
$(asciidoc_product) :
../config.status --file=$@;
+torify.1 : torify.1.in
tor-gencert.1 : tor-gencert.1.in
+torify.html : torify.html.in
tor-gencert.html : tor-gencert.html.in