aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-01-18 22:15:38 +0100
committerSebastian Hahn <sebastian@torproject.org>2010-01-27 12:13:05 +0100
commit9fe1c000b0b1a91acf605ef71a538da7b7218fe9 (patch)
tree717008dd8a0d06d0c850e0bcbb3e981a297c72f0 /doc/Makefile.am
parent3efadcd0d5373cc38986cdf93d03a1d99ec8aee0 (diff)
downloadtor-9fe1c000b0b1a91acf605ef71a538da7b7218fe9.tar
tor-9fe1c000b0b1a91acf605ef71a538da7b7218fe9.tar.gz
Allow generating documentation from asciidoc in the Makefile
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index f8e17ecd3..2eae7a187 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,12 +1,36 @@
+asciidoc_files = tor-gencert
+
+html_in = $(asciidoc_files:=.html.in)
+
+man_in = $(asciidoc_files:=.1.in)
EXTRA_DIST = HACKING \
tor-resolve.1 tor-gencert.1 \
+ $(html_in) $(man_in) $(asciidoc_files:=.1.txt) \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt torify.1
-man_MANS = tor.1 tor-resolve.1 tor-gencert.1 torify.1
+nodist_man_MANS = tor.1 tor-resolve.1 tor-gencert.1 torify.1 $(asciidoc_files:=.1)
+
+doc_DATA = $(asciidoc_files:=.html)
+
+asciidoc_product = $(nodist_man_MANS) $(doc_DATA)
SUBDIRS = design-paper spec
DIST_SUBDIRS = design-paper spec
+# Generate the html documentation from asciidoc, but don't do
+# machine-specific replacements yet
+$(html_in) :
+ $(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+
+# Generate the manpage from asciidoc, but don't do
+# machine-specific replacements yet
+$(man_in) :
+ $(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+
+# use ../config.status to swap all machine-specific magic strings
+# in the asciidoc with their replacements.
+$(asciidoc_product) :
+ ../config.status --file=$@;