aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2011-11-11 12:34:03 -0500
committerNick Mathewson <nickm@torproject.org>2011-11-11 12:35:08 -0500
commitff93535c71a52b327047819a2aeb5372384f859c (patch)
tree6db870ccc38ff8fcf64b5edfc9467a4588095e69 /configure.in
parenta2ecf131f335132518a94a9a2cd831f8bd66bf56 (diff)
downloadtor-ff93535c71a52b327047819a2aeb5372384f859c.tar
tor-ff93535c71a52b327047819a2aeb5372384f859c.tar.gz
New src/test/bench.c to allow us to actually _run_ benchmark code
Yes, the timing functions are suboptimal. Please improve!
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 17f5c8d5e..d13b54d93 100644
--- a/configure.in
+++ b/configure.in
@@ -276,6 +276,7 @@ AC_SEARCH_LIBS(socket, [socket])
AC_SEARCH_LIBS(gethostbyname, [nsl])
AC_SEARCH_LIBS(dlopen, [dl])
AC_SEARCH_LIBS(inet_aton, [resolv])
+AC_SEARCH_LIBS([clock_gettime], [rt], [have_rt=yes])
if test "$enable_threads" = "yes"; then
AC_SEARCH_LIBS(pthread_create, [pthread])
@@ -288,6 +289,7 @@ dnl exports strlcpy without defining it in a header.
AC_CHECK_FUNCS(
accept4 \
+ clock_gettime \
flock \
ftime \
getaddrinfo \
@@ -363,9 +365,6 @@ dnl On Gnu/Linux or any place we require it, we'll add librt to the Libevent
dnl linking for static builds.
STATIC_LIBEVENT_FLAGS=""
if test "$enable_static_libevent" = "yes"; then
- dnl Determine if we have clock_gettime in librt
- AC_SEARCH_LIBS([clock_gettime], [rt],
- [have_rt=yes])
if test "$have_rt" = yes; then
STATIC_LIBEVENT_FLAGS=" -lrt "
fi