aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSteven Murdoch <Steven.Murdoch@cl.cam.ac.uk>2011-07-20 16:07:13 +0100
committerSteven Murdoch <Steven.Murdoch@cl.cam.ac.uk>2011-07-21 13:09:50 +0100
commit2eca0165945f4caddf0585f3f9a33e422f1deeb1 (patch)
tree077be5d71f428872175ddc03ba268243e60da380 /configure.in
parentc2d3da6303a6a5e41eabcb18b56ee5d8434a9817 (diff)
downloadtor-2eca0165945f4caddf0585f3f9a33e422f1deeb1.tar
tor-2eca0165945f4caddf0585f3f9a33e422f1deeb1.tar.gz
XXX Hack to allow tor-fw-helper to be built on Windows
For some reason, --with-libminiupnpc-dir doesn't work on Windows, so this hardcodes /local/lib as the path in which libminiupnpc.a can be found. Also, libminiupnpc needs libws2_32 and libiphlpapi under Windows, so this hardcodes these libraries when building the ./configure test program. These changes almost certainly break *nix, so should be fixed before merge.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0a018628d..f11135548 100644
--- a/configure.in
+++ b/configure.in
@@ -559,7 +559,7 @@ dnl There are no packages for Debian or Redhat as of this patch
if test "$upnp" = "true"; then
AC_DEFINE(MINIUPNPC, 1, [Define to 1 if we are building with UPnP.])
- TOR_SEARCH_LIBRARY(libminiupnpc, $trylibminiupnpcdir, [-lminiupnpc],
+ TOR_SEARCH_LIBRARY(libminiupnpc, $trylibminiupnpcdir, [-lminiupnpc -lws2_32 -liphlpapi],
[#include <miniupnpc/miniwget.h>
#include <miniupnpc/miniupnpc.h>
#include <miniupnpc/upnpcommands.h>],
@@ -567,7 +567,7 @@ if test "$upnp" = "true"; then
const char * minissdpdsock, int sameport);],
[upnpDiscover(1, 0, 0, 0); exit(0);],
[--with-libminiupnpc-dir],
- [/usr/lib/])
+ [/local/lib/])
fi
AC_SYS_LARGEFILE