aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-05-16 22:16:13 +0000
committerNick Mathewson <nickm@torproject.org>2007-05-16 22:16:13 +0000
commitb4bd9f772ccc9e1570116a690c8bb99242b7a14a (patch)
tree6220947a672554da1a6c58436caa00fcbf8299b5 /configure.in
parent2988d797eb90657275be2de6e2b4cf0155a3a3e5 (diff)
downloadtor-b4bd9f772ccc9e1570116a690c8bb99242b7a14a.tar
tor-b4bd9f772ccc9e1570116a690c8bb99242b7a14a.tar.gz
r12771@catbus: nickm | 2007-05-16 18:12:32 -0400
Make -Wstrict-overflow=5 happy with GCC 4.2. It is kind of a pain, but it does agood job of letting us know where we can make our code better by simplifying dependent conditionals. svn:r10201
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 67560498a..6e7f79f46 100644
--- a/configure.in
+++ b/configure.in
@@ -631,8 +631,7 @@ if test x$enable_gcc_warnings = xyes; then
# These warnings break gcc 4.0.2 and work on gcc 4.2
# XXXX020 Use -fstack-protector.
# XXXX020 See if any of these work with earlier versions.
- # XXXX020 See if we can get -Wstrict-overflow=x for x>1 working.
- CFLAGS="$CFLAGS -Waddress -Wmissing-noreturn -Wnormalized=id -Woverride-init -W"
+ CFLAGS="$CFLAGS -Waddress -Wmissing-noreturn -Wnormalized=id -Woverride-init -Wstrict-overflow=5"
fi
##This will break the world on some 64-bit architectures