aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-10-04 10:56:33 -0400
committerNick Mathewson <nickm@torproject.org>2012-10-04 10:56:33 -0400
commitd92d3f33356af002892ba5754d9d36cc4504c95f (patch)
tree54476dbc728c97eab589529ae7fb69b948fb6719 /configure.ac
parent91b18b12d9796d4a71854dd7465c32ee8d500629 (diff)
downloadtor-d92d3f33356af002892ba5754d9d36cc4504c95f.tar
tor-d92d3f33356af002892ba5754d9d36cc4504c95f.tar.gz
Add autoconf magic to support Bitrig
Bitrig is an openbsd fork. Patch from dhill. Ticket 6982.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4db1a2cb8..bb7ea6b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -743,7 +743,7 @@ if test x$transparent = xtrue ; then
if test x$transparent_ok = x1 ; then
AC_DEFINE(USE_TRANSPARENT, 1, "Define to enable transparent proxy support")
case $host in
- *-*-openbsd*)
+ *-*-openbsd* | *-*-bitrig*)
AC_DEFINE(OPENBSD, 1, "Define to handle pf on OpenBSD properly") ;;
esac
else
@@ -1252,7 +1252,7 @@ if test x$enable_gcc_warnings = xyes || test x$enable_gcc_warnings_advisory = xy
CFLAGS="$save_CFLAGS"
case $host in
- *-*-openbsd*)
+ *-*-openbsd* | *-*-bitrig*)
# Some OpenBSD versions (like 4.8) have -Wsystem-headers by default.
# That's fine, except that the headers don't pass -Wredundant-decls.
# Therefore, let's disable -Wsystem-headers when we're building