aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-01-16 10:29:11 -0500
committerNick Mathewson <nickm@torproject.org>2013-01-16 10:29:11 -0500
commitb987081941bda22e5e37a09c75ffc790c270624b (patch)
tree06837e1f3a483cb5ea133b5f808c3d5fafd7be52 /configure.ac
parentf57722d23ec82b711fffc46a8649a8651df7125a (diff)
downloadtor-b987081941bda22e5e37a09c75ffc790c270624b.tar
tor-b987081941bda22e5e37a09c75ffc790c270624b.tar.gz
Check for nacl headers in nacl/ subdir
Fix for bug 7972
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acd20838d..f047ab902 100644
--- a/configure.ac
+++ b/configure.ac
@@ -689,13 +689,20 @@ if test x$enable_curve25519 != xno; then
[tor_cv_can_use_curve25519_donna_c64=cross],
[tor_cv_can_use_curve25519_donna_c64=no])])])
+ AC_CHECK_HEADERS([crypto_scalarmult_curve25519.h \
+ nacl/crypto_scalarmult_curve25519.h])
+
AC_CACHE_CHECK([whether we can use curve25519 from nacl],
tor_cv_can_use_curve25519_nacl,
[tor_saved_LIBS="$LIBS"
LIBS="$LIBS -lnacl"
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([dnl
+ #ifdef HAVE_CRYPTO_SCALARMULT_CURVE25519_H
#include <crypto_scalarmult_curve25519.h>
+ #elif defined(HAVE_NACL_CRYPTO_SCALARMULT_CURVE25519_H)
+ #include <nacl/crypto_scalarmult_curve25519.h>
+ #endif
#ifdef crypto_scalarmult_curve25519_ref_BYTES
#error Hey, this is the reference implementation!
#endif