aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-11 16:29:06 -0400
committerNick Mathewson <nickm@torproject.org>2013-03-11 16:29:06 -0400
commit051b1e8ac4114fb23904cdf8dead72d585904e0a (patch)
tree9135f0b54a5628f08daa03af60c2b15e4f117777 /configure.ac
parentef4db3169344567f30fb72e3e9a66154b976d889 (diff)
downloadtor-051b1e8ac4114fb23904cdf8dead72d585904e0a.tar
tor-051b1e8ac4114fb23904cdf8dead72d585904e0a.tar.gz
Look at the right variable when warning about signed size_t.
In 81d69f4c2d8a451 (0.2.21-alpha) we added a compile-time check for a (totally broken) signed size_t. In 0e597471af (not yet released) I switched to a better configure-time check, which stored its output in a different variable. I didn't change the code which looked at the output, however. This bug is not in any released version of Tor, and would not affect anybody with a working Tor.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 864477b8f..4bc0db363 100644
--- a/configure.ac
+++ b/configure.ac
@@ -980,7 +980,7 @@ AX_CHECK_SIGN([size_t],
#endif
])
-if test "$tor_cv_size_t_signed" = yes; then
+if test "$ax_cv_decl_size_t_signed" = yes; then
AC_MSG_ERROR([You have a signed size_t; that's grossly nonconformant.])
fi