aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch')
-rw-r--r--debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch b/debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch
new file mode 100644
index 0000000..b58f31d
--- /dev/null
+++ b/debian/patches/05_do-not-use-embedded-ssl-match-hostname.patch
@@ -0,0 +1,56 @@
+Description: Do not use embedded copy of ssl.match_hostname.
+Author: Daniele Tricoli <eriol@mornie.org>
+Forwarded: not-needed
+Last-Update: 2014-09-23
+
+--- a/test/test_connectionpool.py
++++ b/test/test_connectionpool.py
+@@ -6,7 +6,7 @@
+ HTTPConnectionPool,
+ )
+ from urllib3.util.timeout import Timeout
+-from urllib3.packages.ssl_match_hostname import CertificateError
++from ssl import CertificateError
+ from urllib3.exceptions import (
+ ClosedPoolError,
+ EmptyPoolError,
+--- a/urllib3/connection.py
++++ b/urllib3/connection.py
+@@ -39,7 +39,7 @@
+ ConnectTimeoutError,
+ SystemTimeWarning,
+ )
+-from .packages.ssl_match_hostname import match_hostname
++from ssl import match_hostname
+
+ from .util.ssl_ import (
+ resolve_cert_reqs,
+--- a/urllib3/connectionpool.py
++++ b/urllib3/connectionpool.py
+@@ -26,7 +26,7 @@
+ TimeoutError,
+ InsecureRequestWarning,
+ )
+-from .packages.ssl_match_hostname import CertificateError
++from ssl import CertificateError
+ import six
+ from .connection import (
+ port_by_scheme,
+--- a/urllib3/packages/__init__.py
++++ b/urllib3/packages/__init__.py
+@@ -1,4 +1,3 @@
+ from __future__ import absolute_import
+
+-from . import ssl_match_hostname
+
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,7 @@
+ url='http://urllib3.readthedocs.org/',
+ license='MIT',
+ packages=['urllib3',
+- 'urllib3.packages', 'urllib3.packages.ssl_match_hostname',
++ 'urllib3.packages',
+ 'urllib3.contrib', 'urllib3.util',
+ ],
+ requires=[],